Error 522 with domain, works with IP

Recently I’m getting Error 522 while accessing my site (https://sk-km.tk), but when I use my IP:port, I can access the site just fine. I’ve read extensively throughout most of the thread regarding to this issue and the #CommunityTip as well, but couldn’t find any solution for my issue.

For context, my site is a self-hosted Laravel site (hosted on my home PC with Apache, domain from Freenom).

From the #CommunityTip Quick Fix:

  1. .htaccess or Firewall are not blocking the CF IPs.
  2. I don’t have a hosting provider and nothing has changed to my site since February, except for database entries.
  3. I checked from few locations using VPN and it connected from nowhere.
  4. There’s no load on my server at all.
  5. Don’t know how to check that.

I’ve checked my Apache settings and they look fine, as my site works with the IP.
My SSL setting is set to Flexible; but I also tried with other options.
Basically, I flipped almost all switches to see if there’s any changes.
My domain is valid, not expired, etc.

What could be the issues in this case? If any additional information is required, please ask.
Thanks in advance.

That’s insecure to begin with.

I suggest you pause Cloudflare, make sure that your site loads fine on HTTPS, and once that works it should work on Cloudflare as well.

Yeah, I’ve got that part as I was reading other threads. But I did try the other options as well.

I don’t know how I could test that. I know how to pause Cloudflare; but if I pause CF I don’t know how it’d point to my computer/IP? I don’t think that option is available on Freenom directly.

All right, for starters, set your encryption mode to Full Strict. Once that is done, pause Cloudflare and we can check what the issue is.

Set Full Strict and paused CF, and now the site did load. What should be next?

I am afraid it does not appear to load.

sitemeer.com/#sk-km.tk

It might be loading for you because you are on the same network, but in generally it does not work and that also explains the 522.

I see what you mean!

Funnily I tried with Firefox and it didn’t load, but it did load with Chrome & Edge. I also tried using mobile data (different network) and Firefox, same issue; but it did work with mobile data and Chrome.

But the detector sites aren’t loading as well!

For that reason I posted the link. Once it loads there, it should work fine.

Check your network settings. Something is stopping requests.

Thanks for all help. So I disabled “Enable DNS over HTTPS” on Firefox and it did work on Firefox as well. So, basically HTTPS is not working at all. I’ll look into it why this could be. But is there any resources I should look at regarding these?

You need to make sure the server is working fine, but that’s not Cloudflare and best discussed in an appropriate forum.

I’m looking into it as I speak. Thank you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.