Error 522 when proxied | no problem when DNS Only

bought domain, change namespace to cloudflare, set up nginx proxy manager access, port forwarding, ssl certificate

everything seems fine and super fast when in DNS only mode in CF. as sson as i activate proxied ( which i want to do for extra security, error 522)

went through tons of answers cant find why, just a toggle and bam nothing work

Please help!

1 Like

May I ask what is the domain name? Moreover, I assume you mean you changed your nameservers to Cloudflare ones, right?

Have you tried accesing your Website with some different Web browser or different device? (maybe clearing your Web browser cache and restarting router due to DNS propagation if the domain is recently bought and added to Cloudflare).

Moreover, who is your hosting provider?
Maybe they blocked something or prevent Cloudflare to connect to your host/origin?

Okay, meaning if you Pause Cloudflare for your domain or temporary switch the :orange: cloud to :grey: cloud it is working properly?

May I ask have you checked the suggestions from the below article?:

Have you allowed Cloudflare IP addresses to connect to your new host/origin?
Maybe you need to allow Cloudflare IP addresses to connect to your host/origin server:

IP list here:

How about your web application?, does it work on a port which is compatible with Cloudflare as follows in the below article:

Is the SSL certificate covering both your main domain and your sub-domain(s) like www?

Can you check what have you got selected under SSL tab at Cloudflare dashboard? Is it Full SSL or something other?

A good thing would be to check here too:

-Nameservers changed to cloudflare
-Tried from a phone connected to cell network, same results

  • porkbun is the registrar. tryint to access home ip using dynamic dns

  • forwarded all incoming traffic to port 80 and to port 443 to my nginx dedicated ports through port forwarding router rules

  • yes if iswitch from orange to gray it works

  • web app port does not matter (nginx tkaes care of this job)

  • SSL good question? using full (strict)( with cloudflare certificate on subdomains only, have not created anythinbg on main domain, was not planning to use it

  • check and activated all security toggles and full stricts

If you use ‘flexible’ SSL then change it to Full (strict). That’s what made my day.
I had exactly the same problem and that changed when I changed my SSL setup

1 Like

I am already in full (strict). not sure what you mean. I can see the origin certificate working properly.

This topic was automatically closed after 31 days. New replies are no longer allowed.