Error 522 since changing isp

Hi,
I recently switch to a new ISP, community fibre, and had been using cloudflare tunnel to access my nextcloud server on my raspberry Pi at home. I have enabled the 443 port on my router and reconnected the cloudflare tunnel on my Pi. I have also updated the DNS settings to match this. However when I type in the domain I get a 522 connection error and the page doesn’t load when I type in the ip address

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.