Error 522 on Forwarding URL

Hi,
I have set up domain forwarding but I am receiving a 522 Error when typing a url directly into Microsoft Edge.

https://www.adamblythphotography.com

I expect this to forward to https://www.adamblyth.com.au on which my smugmug site is linked.

Previously my site was on the first url in this post, however I changed this earlier today to be on the second url.

Am I being impatient and this will take some time to resolve or is there an underlying issue?

Thanks,
Adam

There are several issues. Forwarding, as well as your second site’s setup.

  1. Forwarding
    adamblythphotography.com forwards properly. Its “www” record however does not. You are probably missing an asterisk in your page rule. Post a screenshot of your page rule list.
  2. Setup
    adamblyth.com.au does not seem to be set up properly either. Are you sure that is configured correctly on your server? Do you have a certificate there? Pause Cloudflare for now and try to fix the site first.

Thanks for the reply sandro.

adamblythphotography.com Page Rules

Could you explain the issues you are seeing with adamblyth.com.au? It is a SmugMug website, I don’t have access to the server. I’m not certain there are server side issues, perahps I have set up Cloudfare incorrectly for this site a well? Note I do not have any Page Rules set up for this url, perhaps I should?

Drop the first page rule and prepend the second one with an asterisk.

As for the second domain, you best pause Cloudflare for now and make sure the site loads fine and only then enable Cloudflare.

Thanks sandro. Will amend the Page Rules.

I can confirm the second url works fine, there are no issues with this site that I can see. It loads fine n several different PCs.

Can I confirm, should I be changing the rule so it has the yellow highlighted section?

This is from Redirecting One Domain to Another

That’s exactly the issue. “www” works, the naked domain does not but redirects to a 404.

You could configure a second redirect for the second domain from the naked domain to “www” but that’s rather a workaround.

1 Like

ok. So something like this:

first url Page Rule

second url Page Rule

Precisely, that should work.

1 Like

Should it work instantly or do these changes take some time to come into affect?
Really appreciate your help here, thank you

Should work within about a minute.

Yep, success! Thank you very much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.