Error 522 on domain having cname to other domain

So on my domain aestron.me, I have a cname record on test.aestron.me to ...dynv6.net which has a AAAA record to an ipv6 address, when I try to access ....dynv6.net it does work. But I cannot access it from test.aestron.me as cloudflare reports a timeout.

You need to make sure that the addresses at IP Ranges are not blocked on your server.

For testing, I added a new AAAA record on testip.aestron.me which points to my ipv6, now when I access http://testip.aestron.me the requests do go through. So the ip ranges are not blocked on my server. But on the test record it just does not work.

Can you post a screenshot of your DNS entries?

to clarify the testip has the ipv6 address of a machine running on the same network as the ipv6 AAAA address of yashasviallen.dynv6.net.

and both the addresses are publicly accessibly by ipv6 clients.

That hostname also resolves to an IPv4 address and that does not seem to work.

Now, it does not.

You need to make sure that all addresses you configured on Cloudflare are accessible by Cloudflare.

yes, they are publically accessible. I assumed they would be cuz they worked for me in browser.

As mentioned, the IPv4 address does not work.

I removed it now, is it still there?

That’s correct, but the IPv6 does not match.

I would recommend to pause Cloudflare altogether and make sure the entire site loads fine on HTTPS. If it doesn’t you need to fix the server.

Once it loads fine on HTTPS, you can unpause.

You could also consider Tunnel if you have a dynamic address.

which ipv6 do not match? the site does work for me on https regularly.

that dynv6 site is for managing dynamic addresses in itself.

You haven’t paused Cloudflare yet.

paused it now.

On browser, the site does load fine with https.

It is not paused.