Error 522 for every record in only 1 domain

Hi,

I have an error 522 with one of my domains.
I know it’s not an issue with the server because when I add the same server IP as subdomain in an other domain B, it works. But no server IP works on the server A.

PS. I tried with A Records and CNAM Records.

Can anyone help please?

Did you check this #CommunityTip ?

If absolutely not the server, then as you as its most likely related to ip. For more details, read the attached article.

Finally I figured it out !

It wasn’t related to the server neither the IP, It was related to SSL/TLS encryption mode (for those interested : select domain > SSL/TLS > Overview).

The selected SSL/TLS encryption mode was “Full” but my server isn’t using a self signed certificate.
So I changed it to “Flexible” (more than enough for my personal project) and it worked like a charm.

It was definitely an issue with the server.

You want SSL, but your server doesn’t have it.

1 Like

It did not. You only dropped all encryption and have an insecure site now.

No it wasn’t.
Never said that I wanted ssl.

For such a personal website that only I use with no sensitive data, I don’t really care about SSL, even http would’ve been fine.
All I wanted is to point the domain to IP to be able to find my website simply without having to remember the IP every time.

But yeah I get your point, in a business website it’s not something to do.

Thank you any way.

That’s a fair point, though then you should the encryption mode to Off. This will ensure there’s no SSL and no issues.

Flexible mode is fine :slight_smile:

It’s not, you need Off if you do not want SSL.

it’s not that I “don’t want SSL”, it’s simply that “I don’t care” if ssl is enabled or not for this particular website.

  • with flexible mode, I don’t have the warning in the browser so I prefer.

You just said that.

If you want SSL, you need to have a certificate on your server as mentioned earlier. Otherwise, just set it to Off and it will work as well.

If I didn’t say that I want SSL doesn’t mean that I want ssl to be specifically OFF, it means that I don’t care if it’s ON or OFF.
One last thing : https is important from blowser to server, so if the the connexion is secure from browser to Cloudflare, why do I need the connexion to be secure from Cloudflare to server?
I know the issue and the “hacking” case when the connexion is unsecure from browser to internet, but I don’t see the issue if the connexion is unsecure from Cloudflare to server and secure from browser to Cloudflare.
Any thoughts on that?

HTTPS is always important, that has nothing to do with the browser. There’s a reason why there’s a dedicated thread on that in addition to the one mentioned earlier.

You essentially have a broken site right now.

Please refer to the two articles posted so far as they have all the necessary information.

If you need SSL, set it to Full Strict and make sure you have a valid certificate, otherwise set it to Off and you won’t need to bother with encryption.