Error 522 - Connection Timed Out


#1

Please help, my website started to show a 522 Error - Connection Timed Out.
I made no hosting/Cloudflare changes, nor had any peaks in traffic/requests that I’m aware of.

My website: https://thesaltbox.co.za/

This is the information I have:


This is from GoDaddy showing the nameservers point to CloudFlare, and that they cannot access or see my settings.

I know this type of question has been asked before, but I am not IT literate and cannot figure out the steps highlighted here: Community Tip - Fixing Error 522: Connection timed out

Thank you so much!


#2

Hi @saltbox,

Great that you found the community tip on the topic (OMG… someone actually uses the search :smile:). Most of the steps there involve asking your hosting provider about something, rate limiting, IP blocking etc, so you should probably ask them about those steps 1,2,4 and 5.


#3

Who is my hosting provider? Would it still be GoDaddy despite them saying they don’t have access to the DNS settings? I phoned them twice already, and explained my issue but they were less than helpful.


#4

Yes, GoDaddy are your hosting provider. They are not known for being the most helpful in these situations. They love blaming everything on Cloudflare!

yes, despite them not having access to your DNS they should still be able to answer the questions. You just may have to ask them these questions (taken from that community tip) very directly!

  1. Are they blocking Cloudflare IPs
  2. Are they blocking or rate limiting requests from the Cloudflare IPs
  3. Can they whitelist the Cloudflare IPs for you?
  4. Are there any load problems on their infrastructure?
  5. Was the server under load or were there packet loss issues when you made the requests to the server?

#5

Thank you, I shall go ahead and inquire.

Last question, are my DNS settings correct? I’m unsure what should be there or not?


#6

Looks correct to me, as long as that IP in the A record matches the one at GoDaddy, then it should be fine.

You have correctly set subdomains like mail to :grey:


#7

Godaddy support said the IPs are not blocked, and that the hosting is not being limited.

If I switch all DNS settings to :grey: I can access the Wordpress site (https in red)

Could it be a plugin, like Jetpack or W3Cache?


#8

I suppose it could be caused by a plugin but I doubt it.

So GoDaddy were unable to help at all and couldn’t tell you why the requests had taken over 15s?!?


#9

Unfortunately the support person offered no advise or insights into the hosting package, they said all resources/CPU/bandwidth is fine. They tried to sell me a native SSL/firewall package. They said no Cloudflare IPs had been blocked or rate limited.

I can only assume my Wordpress system (and plugins) are causing the slow requests?

I was thinking of making my site temporarily insecure, going in and disabling the caching plugins, purging cache, and checking that?

What typically causes a slow response time? My website is just a simple blog with under 100 visitors a day.


#10

How slow are your requests without Cloudflare?


#11

I don’t know where to see the speed of my requests, but I assume they are slow.
Sigh, everything was working fine with the website (SSL + load times) for the past 10 months. On Sunday I got a notification from Jetpack stating the website was down. It has been two days with the 522 connection timed out code.

I wish Cloudflare support would respond and advise me, as I was enjoying the free plan. I am now in a position where I will need to switch back to HTTP and revert to Godaddy nameservers, rather than lose traffic/business from the website…


#12

I’m seeing that the self-signed certificate is for aronfrost.com and not for your domain. Also, having dealt with sites on GD, it doesn’t take much traffic (if any), to cause it to stop responding especially the shared packages with 1CPU, 512MB ram and 100 entry processes. Throwing more money at it don’t help much either. In most cases, CF buys you time before you really need to consider switching hosts to get more for less.


#13

Hello, I have adjusted the SSL certificate to the signed, cloudflare one:

I have 4 Wordpress sites under the deluxe shared hosting package of GoDaddy, with only this website running through Cloudflare and showing the 522 error. The other 3 websites are HTTP unsecure and work load fine.

So it is likely the few hundred visitors a day, and bigger pages/more plugins, on this URL is causing the slow requests?


What is my best action for quickly fixing this issue? Switch hosting? Disable CF?

I would really appreciate any advice on what steps I should take right now? As the website is down.

Thanks


#14

With all honesty, I’ve seen sites on the GD deluxe package struggle with just 1 WordPress site and 10~20 (or less) visitors per hour and that’s with every possible optimization.

To test speed and connection reliability, I ran tests which isn’t different than a regular visitors on both and they were affected the same. The static page was slightly faster but it’s only a few lines of code and one image and began to see both sites stopping but with Cloudflare, you get to see the error and again, it’s helping by reducing hits to the origin.

aronfrost.com (a static web page)
https://www.dotcom-tools.com/website-speed-test.aspx#BAC78EEBC5E944ACA173135AB4E1B38D

and

thesaltbox.co.za (web app requiring more resources e.g. database & plugins)
https://www.dotcom-tools.com/website-speed-test.aspx#92D0BAC144A44A6781309216E99B40C9


#15

Thanks

I am now transferring my domains/hosting away from GoDaddy.


#16

Sorry to be the bearer of bad news but at least your getting an honest answer here. If you do search for another host, let us know your Region/Country and maybe someone here can suggest a better hosting company.
Also, keep an eye out for hosts that offer SSD storage, at least 1~2 GB ram, 1~2 CPU’s, unmetered bandwidth, unlimited hosts/databases (if you plan on having more that 4 sites) and cPanel to make thing easy to setup.


closed #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.