Error 522 "Connection timed out" though I have SSL and HTTPS

I am hosting the origin server myself and I have setup the following:

  • Valid certificate and private key
  • SSL all setup
  • SSL/TLS encryption mode Full (strict)
  • DNS records setup
  • Firewall allowing correct ports

I have nginx running on the server with the correct reverse proxy yet I still get Error 522
The tutorial post for Error 522 doesn’t help me at all.

If I also go to the domain but don’t manually start it with https://, Opera GX will say that it doesn’t support HTTPS even though I have “Always Use HTTPS” set to on.

What happens if you disable Cloudflare for the site? Are you able to load it, or does it also fail? You can either pause Cloudflare by putting your site in development mode or disable the proxy status for the domain.

I’ve put it in Development Mode and disabled proxy status and it still goes to the Connection timed out page.

Also to confirm about the IPv4, I use the public IP of the origin server for the DNS record right?

Had to wait a bit for the Development Mode thing to stop using Cloudflare, going to the domain just shows “This site can’t be reached”.

If it times out without Cloudflare. That would be something to check with your hosting provider, once it works without Cloudflare then it should work when you re-enable Cloudflare.

I’m hosting it myself with my own server.

Gotcha, then you need to figure out why your server isn’t publicly accessible. If you don’t want it to be publicly accessible, then you can check out Tunnels

1 Like

Thank you so much, it works now!!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.