Error 522 Connection timed out sometimes pops up

Hello good people,

we recently activated Cloudflare and for the most part, everything is working perfectly fine! For some users though, sometimes the error 522 “Connection timed out” pops up. It is not always for them, just sometimes, and is also dependent on the browser (for one colleague, it worked in Chrome, did not work in Safari and Firefox on Mac). Does anyone know why this happens and how I can fix it?

Thanks in advance and best regards,
Ulli

Hi @digital19

I have tried to change your SSL certificate from GTS to Let’s Encrypt. This might solve your issue, or else try and troubleshoot 522.

Hi @louise2,

thank you for your help and effort! However, that did not do the trick unfortunately, it still occurs. Do you still have any other ideas? I am of course trying the things from the link you posted. Thanks!

If it helps, maybe it has something to do with non-whiteliste IP adresses from Cloudflare? Can I send them somewhere private or is it alright to post them here? Thanks!