Error 522 - Connection Timed Out on all the Websites in my Hosting

I have been experiencing this issue for more than 48 hrs now. Error 522 - Connection Timed Out. This is happening to all of my Websites on my Cloudflare Dashboard.

I host these sites with Godaddy and I have been in touch with support and we have done several changes including adding a new IP in DNS Records and Purging my Cache on Cloudflare.

So far the issue has not been solved nonetheless. The new advice is that I should ask Cloudflare to update the SSL Certificate.

I need help to fix this

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an error 522 with your WordPress website.

I’d suggest you to re-check with the GoDaddy and for any maintenance work at their network just in case.

More information about why this error appears and how to fix this issue could be found at the below article:

Furthermore, kindly re-check with your hosting provider and your firewall if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Before moving to Cloudflare, was your Website working over HTTPS connection?

Is GoDaddy providing you with an SSL certificate for your domain names including with the hosting or? :thinking:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domains ( Flexible, Full, Full Strict … )?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / GoDaddy SSL / Certbot / Let’s Encrypt / ACME and renew it
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

It’s actually not just my WordPress websites, 2 are static and 2 Wordpress.
On all of them, I am using Full Strict which after attempting to switch off completely has no effect.

Also, Godaddy is only offering my hosting and my domains, on the other hand, I rely on Cloudflare for SSL.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.