Error 522 Connection timed out host-domain

#1

Hello,
I want to ask how can DNSs work legally by adding them to a domain (03/04/2019 14/15), but I see that nothing else happens, where to look for the problem in the Domain Provider or in my hosting?

for ease of use, will also attach photos.

img3
img4

1 Like

Can not access wordpress dashboard
#2

A 522 is when your site doesn’t respond to Cloudflare.

Try using the “Pause Site on Cloudflare” option on your Overview page to see if the site will work this way.

0 Likes

#3

Do you propose to try using this option?

Pause Cloudflare on Site

0 Likes

#4

Yep, that’s the one.

0 Likes

#5

so it works, but when I activate it again stops

0 Likes

#6

It sounds like your host is blocking Cloudflare.

0 Likes

#7

Yes, but how can I fix it not to block Cloudflare.

OS: Debian 9 server

0 Likes

#8

Some ideas :?

0 Likes

#9

What exact server? And would you be willing to attach your /etc/hosts.deny & /etc/hosts files, taking care to remove personally identifiable information?

0 Likes

#10

Attach photos with the information in these two files you wrote

Server Os : Linux Debian 4.9.144-3.1 (2019-02-19) i686

/etc/hosts

/etc/hosts.deny
[Personal info Redacted by Staff]

1 Like

#11

The server software; I should’ve been more precise when asking. Some prefer using various ones (Apache, HAProxy, Nginx, as examples).

In the meantime I see you’ve - rather Debian did when doing its install - locked 192.0.0.103 to your device’s ‘domain name’. So I’m assuming you’re not using Ethernet and instead using a wireless connection. This may not be having any effect on your issue, but that router - if it’s using DHCP, if your machine isn’t using a static IP address - it very well may be.

0 Likes

#12

I use it: Apache/2.4.25 (Debian) PHP version: 7.0.33-0+deb9u3
mysql Ver 15.1 Distrib 10.1.37-MariaDB, for debian-linux-gnu (i686) using readline 5.2

You can write to me in Skype: Linux_bg- or E-mail: [email protected]

1 Like

#13

One last request after you update your machine’s IP to a static one - and I should have asked already - but pls attach your /etc/hosts.allow - we may be able to tweak it to allow explicit connections to Cloudflare for you.

0 Likes

#14

Will do :slight_smile:

0 Likes

#15

result of the hosts.allow file

hosts.allow

otherwise the IP address is static, the site is currently working because I gave it

Advanced Actions

Enable Cloudflare on Site

currently the site is at the pause in Cloudflare.com

1 Like

#16

I’ll get back to you via email after I sleep. Anyone here, of course, is welcome to help. Thanks :sleeping:

0 Likes

#17

yes, all welcome ideas or someone if you have a similar problem will be happy to share it

1 Like

#18

apparently nobody has encountered this problem

0 Likes

#19

I want to share, the result of error problem 522,
The problem was in the certificate SSL

I stopped

Always Use HTTPS

Redirect all requests with scheme “http” to “https”. This applies to all http requests to the zone.

and the site connects to DNS in cloudflare, but without sacrifice SSL

0 Likes

closed #20

This topic was automatically closed after 14 days. New replies are no longer allowed.

0 Likes