Error 522, Cloudflare tunnel was working for 2-3 weeks, But now it is not


We have a problem with my cloudflared tunnel. I had created a few weeks ago an Cloudflare Tunnel in zero trust dashboard, connected the tunnel to Cloudflare with “cloudflared.exe service [token]” and the configurated tunnels started to work.

Now, we can’t access to our host anymore and get the 522 Error. I can absolutely confirm that the Cloudflare service and our webserver is running, since we can access it on the local host.

I’ve spend over 10-15h in multiple things to run this again. Even the simplest example with a quick tunnel with “cloudflared tunnel --url localhost:3000” is not working anymore on the host. (It does on my private pc when I do exact the same thing)

Do you guys have any ideas why this could happen? Could it be that the internet provider (AT&T) start to block somewhen? Since this host is running under private household

Thank you so much in advanced, i am really desperate rn…

Solved it, i guess… We had changed the domain a weeks ago. The old domain had Pro, and the new one Free. Since we have a bit more higher traffic via websockets - the traffic volume of new domain was probably used up

It would have been good if we had received a notification or email instead of throttling the traffic without any info… :confused:

Nah… it worked after changing back to the pro domain for a few hours. Now its still not working. May we need to upgrade to Business? But it cant be cuz even not the simplest “hello world” applications without any websockets is not working