Error 522 - Can't find the problem

BTW: I’m not using incognito

So it only occurs when in incognito mode?

Have you resolved your issue regarding error 522?

It loads fine and working correctly form my end now.
Tested 3 Web browsers + incognito mode + mobile ISP network.

1 Like

Yeah still can’t replicate it

No, also in normal mode.

I got the error a few minutes ago in a normal browser window. I opened the homepage, then clicked on a post. The featured image was not there, so I clicked on reload and got an Error 522. This was on another website on that server.

Have you tried restarting your router and clearing your Web browser cache?

May I ask who is your hosting provider? Maybe they blocked something or prevent Cloudflare to connect?

Does anything changes if you Pause Cloudflare for your domain?
Or temporary switch the :orange: cloud DNS records to :grey: cloud?

May I ask have you checked the suggestions from the below article?:

Have you allowed Cloudflare IP addresses to connect to your new host/origin?
Maybe you need to allow Cloudflare IP addresses to connect to your host/origin server:

IP list here:

How about your web application?, does it work on a port which is compatible with Cloudflare as follows in the below article:

May I also ask if you have got an SSL certificate for your domain and your sub-domain(s) installed at your host/origin server?

Can you check what have you got selected under SSL tab at Cloudflare dashboard? Is it Full SSL or something other?

Have you tried writing a ticket and contacting Cloudflare support due to your account and/or domain issue?

Yeah cause no error on my end

Hi!

Thanks for your help. No, I still get random Error 522 on the websites on my server. It’s hard to replicate with a specific process. I think, when a page is loaded correctly, it will load correctly from then on. Only when a page is loaded the first time it maybe can produce an Error 522. Or when it’s loaded with missing elements (like a featured image) and you reload the page, it can happen too.

It maybe happens when I purge the cache. It maybe happens when the cache is expired.

I don’t know all this technical stuff, but I think there is something wrong in the communication between Cloudflare and my server. Is there a way to find out, what and how they communicate?

So random 522’s?

Yes

The server is on Google Cloud Platform with Ubuntu 18.04 and Webinoly. I whitelisted all CF IPv4 in the firewall settings.

Yes, then the problem doesn’t exist anymore. I then get no errors.
This site www.katzensofa.blog was not accessible this morning so I turned the orange cloud into gray. It still is gray and the traffic goes directly to my server.

Yes

Cloudflare IP addresses are whitelisted.

It’s port 443. Port is open.

Yes, I have a Let’s Encrypt Certificate installed.

It’s on Full (not Full strict). I read hat Full is faster than Full strict. That’s why it’s on Full.

No, not yet. I wanted to ask the community here first.

Well have you tried enabling “development mode”?

Random =

  • It happens on all webpages on that server when on Cloudflare proxy.
  • It does not happen only on specific URLs.

Well “DNS Only” mode can expose your server’s IP addresses

Yes, I tried development mode. I could not replicate the error then. But I only tested it twice but with the same process, I once could replicate the error.

Yes, it exposes my IP address. That’s one reason I use Cloudflare. The other reason is that my server has websites on it with audiences in the US and in Europe.

So I would love if we can solve the problem. :smiley:

And an exposed IP address is a security risk

What is your security level set to?

I’ll keep trying to regenerate the error

Maybe there is a certain record that (when proxyed) is causing connections to time out, this maybe time-consuming but try doing the records one by one to proxyed (first set them all to proxied) then set them all to DNS only 1 by 1 until it no longer shows the error

Yes, I know that it’s a security risk. But for the moment I only have two options:
Security risk vs Error 522

Security level is set as medium.