Error 522 - BlueMap

big breath

My domain host is Google Domains, but I have all the DNS server settings rerouted to CloudFlare so I may use the proxy services. The proxy services are turned off for a Minecraft server I am running, because that gets rerouted over to TCPShield and it protects me just fine. The Minecraft server I am hosting is having zero issues ( I’m hosting a plugin on that Minecraft server and it’s for a dynamic map called “BlueMap”. The default port has been changed from it’s original 8100 to 8080 so CloudFlare would support it. I have all the ports forwarded properly, and I’m sure of this because I can access the map outside of the network using the external IP (x.x.x.x:8080), and it loads up just fine. I added an A record to point “” to that external IP so that the players in that server can just use “” to access it instead of exposing the network’s IP address. When I try to access the map using the URL in the A record, I get an Error 522 “Connection Timed Out” and it’s at the host level.

What am I doing wrong here?
The config files on the plugin are clearly correct since I can access the map using the external IP.
The ports are forwarded correctly at the router since I can access the map using the external IP.
I’ve added all IPv4 addresses to the host system’s iptables (Debian).

I talked to the lead developer of BlueMap, “Blue” and he says he doesn’t mess with CloudFlare and has no idea. He just recommended NGINX or setting up and Apache2 server, but I’m not wanting to set those up.

Hi @jarhead2013,

Firstly, does it work with the proxy turned off, that will give a good indicator as to what the issue is.

Secondly, are you specifying the port like When you request it? If not, do you have something on the server to handle that and serve it on the default 80/443?

Also, 8080 is an HTTP port, so won’t work on HTTPS anyway.

Personally, I would use Cloudflare Tunnel for this use case. This will directly allow you to handle routing the traffic to the right application on the server. You can do it without this, but would need additional setup server-side.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.