Error 522 After enable Cloudflare Load Balancer

I have site called which is pointed with proxied dns record
its working fine

Now I have replicated server and it have ip called

I have enabled Cloudflare load balancer on my site with hostname called and its also proxied

I have created one pool which have two origin called

Now whenever I enable Load Balancer, I am getting 522 connection timed out error and as soon as I disable load Balancer, its start working. I am not getting why its causing issue like this, I have checked my both server and its up and running fine.

Let me know if someone here can help me for the same


A 522 error typically happens when Cloudflare requests to the origin (your webserver) get blocked. Review the suggestions in this Community Tip for troubleshooting ideas.

Thanks for your reply. As I have mentioned its only causing issue of 522 if I enable Load Balancer, its working fine if I disable Load Balancer. So I think issue is related Load balancer.

I don’t think the issue is the load balancer, I think your origin server(s) or firewalls are blocking Cloudflare

I have no firewall installed on server. as I have told, its working fine if I disable load balancer.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.