Error 521 - Website down (but not really down)


All of my websites are working great through CloudFlare, except one…

On the non-working site, the domain and sub-domains return “Error 521”. If I turn off the Proxied option in DNS, or if I specify my web server’s IP address in my hosts file, it works fine, but not through CloudFlare. All of my other websites are hosted on the same server. I have firewall rules that permit all CloudFlare IPs. Even if I open up port 443 to the world it still does not work. CloudFlare thinks the website is down but when I test it manually, it’s not down.

I removed the domain from CloudFlare then a few minutes later added it back, but that did not help.

What else should I look for to fix this issue?

Thank you,

■■■■, can one of the moderators please change the subject to “Error 521 - Website down (but not really down)” ??

My auto fill put in my email address by mistake.

1 Like

I presume you did double check that the IP addresses on Cloudflare are correct, right?

What’s the domain? And also post one that works.

Yes, IP is correct.


Not Working:

Can one of you please flag this topic so a moderator can fix the title/subject?

Please thank thank you!

You can flag yourself too. You should even be able to edit it.

As for the issue, your webserver’s IP address does not happen to end in 213, does it?

I don’t have an option for edit, and when clicking Delete it says “You don’t have permission to delete this topic. If you really want it to be deleted, submit a flag for moderator attention together with reasoning.”

It does not have 213 in it.

Did you try flagging it?

Does it end in 154? Though if you say you blocked it on a firewall level, that will be difficult to debug anyhow. A 521 is typically when Cloudflare cannot reach your server. In your case that should not be the case as other sites on the same machine are working. Are all sites running on 443 and are all sites on Full Strict?

I don’t have an option of flagging it.

My home IP has 154 in it? All my sites are on flexible.

The weird part is that it was working several months ago.

Your encryption mode would explain it, as that will never go via 443. Switch them to Full Strict, make sure they all have certificates, and try again.

It worked. I guess I didn’t understand the ‘Flexible’ option.

Thank you so much!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.