Error 521 - Unable to have support

Hi All,
i’ve a problem!
There are few Days that my website (www.cocambo.com) gives Error 521, web server is down.
The domain is registered on Aruba.it with dns managing only. The hosting is on cloudflare.
I’ve changed nothing setting on Aruba or Cloudflare in the last year and the site was always up with no problems. In the last 2 days i’ve this error.

Aruba support tells me that i have to poke to Cloudflare and the Cloudflare automatic support say me that there is a problem with the webserver. But where is the webserver???
Please help me!!!

Here the automatic answer of the cloudflare support:
Thank you for contacting Cloudflare Support.

A 522 error happens when a TCP connection to the web server could not be established. This typically happens when our requests to the origin (your webserver) get blocked.

We have run an automated test and can see that there are a high number of 522 errors showing on your domain cocambo.com :

  • 499: 473
  • 522: 370
  • 521: 171
  • 200: 77
  • 301: 77
  • 304: 5
  • 403: 2
  • 525: 1

On your domain, the following origin IPs are showing the most amount of 522 errors.

  • 80.211.6.74
  • 62.149.128.160

Regarding 521 errors:

Kindly, check your SSL settings too.
Do you have an valid SSL certificate at your origin/host for your domain and your sub-domains? Also, which SSL mode have you got enabled (Full SSL, …)?
Did you have had an SSL certificate before moving your domain/website to Cloudflare?

Kindly, check the steps from below article to make sure you have the right SSL setup:

May I ask who is your hosting provider?
Have you tried contacting them to make sure Cloudflare is allowed to connect to their server/host and not being blocked?

I am afraid but this is incorrect statement as Cloudflare is not a hosting provider company.

May I ask on which port is you app working?
Is the port compatible with Cloudflare ones from below article?
https://support.cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

May I ask have you tried the steps from the below article?:
https://support.cloudflare.com/hc/en-us/articles/201897700-Allowing-Cloudflare-IP-addresses

Cloudflare IP address list can be found here:

Regarding 522 errors:

1 Like

I don’t know who is the hosting provider. How can i find it?
I’ve contacted Aruba (where i bought the domain and DNS managing) and that said me to talk with cloudflare. I’ve changed nothing in last time so i think that the hosting (i don’t know where the files are hosted) is expired; that could be the only reason. Anyone knows what can i do?

EDIT: i’ve no 522 errors. I’ve typed 521 error on the support request and the support automatic answer is talking about 522… don’t know why.

Thanks

By the history lookup for A type DNS records for your domain cocambo.com, it should be Aruba S.p.A.:

If correct WHOIS data, the domain cocambo.com was purchased by Tucows.

Are you sure you do not have any other services at Aruba?

In that case, you would need to purchase a web hosting space for your domain.
Furthermore, point your DNS records at Cloudflare dashboard to the new IP address which you would get from your new hosting provider.
If the hosting is expired and you do not know who the hosting provider was, I am afraid you cannot get back the old files.

If you contacted Cloudflare support, may I ask to post your ticket number here?

Yes i’ve already checked it. Tucows domain exists as hosting provider?

I suppose that the only reason because i’ve 521 error is the hosting expired, i don’t know it for real because i don’t know where the files are located.

Ticket number 2197216 .

@cloonan could take a look.

Kindly and patiently wait for another reply.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.