Error 521 on subdomain

I get an error 521 when I try to connect to my subdomain
Let’s just call my domain
If I connect to it works
but if i connect to it doesn’t work
Under DNS Records they are both Type A, Same IP address and Proxy status is Proxied
These are the only ones listed under DNS Records
Nameservers are also set to Cloudflare Nameservers
If I ping them I get a reply back from both of them
I have created an Origin Certificates which is set to * and
SSL is set to Full

Let’s not call your domain test because that is a real domain. Let’s use one of the domains that is reserved for such purposes, specifically

Is your origin server configured to respond to requests for the hostname What happens when you set the test hostname to :grey: DNS Only?

thanks, I’ll use that in the future, it’s the first time I write on a forum about something like this
I’ve tried turning it off where it didn’t work and pausing Cloudflare to no avail
But then today it worked, so it took about 5 days to work from the first time I set it up?
thank you for writing to me

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.