Error 521 on site NOT using Cloudflare

Hi there, Joomla site is getting Error 521 but… the site does not use Cloudflare. I have no idea where this id coming from…

Any insight is greatly appreciated - as this site is only active for a short period of the year (deals with event registration), this is extremely urgent.

Thank you!
Gina G.

Then the community can’t help you!

Maybe web browser cache? :thinking:
May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Otherwise, if you maybe changed your hosting, it might be something related to the SSL certificate.

Have you tried reaching to your old hosting provider?
Did you used Cloudflare for your domain name before?
Can you share your domain name here?

1 Like

Hi and thanks for the response!
I ‘fixed’ it by forcing https and www through .htaccess
However, that does not explain where a request to couldflare came from in the first place. I’ll keep diggin.
Anywho… I’m good for now - thanks again

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.