Error 521 GoDaddy and Cloudflare

#1

Guys,

I just pointed my Cloudflare name servers to my goDaddy domain and added all the A, CNAME record types for the domain in Cloudflare DNS tab.

I also setup the free SSL certificate on cloudflare but now my site is not working, it gives Error 521 if I look in the browser console. I understand what 521 is but how do I troubleshoot and fix it?

0 Likes

#2

Does your host have configured a certificate for your site? Whats the domain?

0 Likes

#3

the domain is: www.luxsant.com
I have a free SSL certificate on cloudflare, nothing on my managed wordpress hosting on goDaddy.

0 Likes

#4

You need a certificate on your server as well, the certificate on Cloudflare is not enough.

0 Likes

#5

Has something changed recently regarding this on Cloudflare? Because previously it worked fine. The reason we are on cloudflare is because they offer a free universal ssl certificate.

0 Likes

#6

Nothing has changed in this regard. You always needed a certificate on your server.

0 Likes

#7

Right, so I need an SSL certificate on goDaddy too?

0 Likes

#8

Yes, exactly. They tend to want to sell certificates, which is certainly an option, but there are plenty of free certificates out there, including Cloudflare’s origin certificates, which you can simply install on your server.

0 Likes

#9

I appreciate your help and can you please share an article that could help with this?

0 Likes

#10

For example https://support.cloudflare.com/hc/en-us/articles/115000479507-Managing-Cloudflare-Origin-CA-certificates

0 Likes

#11

Let me try and I’ll get back to you. Appreciate your time.

1 Like

#12

Well, my goDaddy hosting does not allow setting up an SSL certificate.

I would still like to reiterate that it was working like this previously.

The wordpress site is hosted on goDaddy (using their managed Wordpress plan), I created an account on cloudflare and pointed cloudflare’s Nameservers to the domain (which is also on goDaddy). After this I just created the appropriate a, txt, cname and srv record types in the dns section on cloudflare (to make my office 365 work and to make the domain work). This is working fine as the domain name is resolved and it takes me to that page but the resources on that page are not fully loaded and if I look into the browser console. There it is showing me 521 error messages like the following:

(index):68 GET https://www.luxsant.com/wp-content/themes/Divi_3.0.19/Divi_3.0.19/style.css?ver=3.0.19 net::ERR_ABORTED 521

0 Likes

#13

In that case I would suggest you switch to a host that allows you to set up a certificate. If not you cannot have a secure site by definition.

1 Like

#14

Right but in this case can you please explain what is the point of the free universal SSL certificate that cloudflare offers? If I have to get it on my original server anyways?

0 Likes

#15

Cloudflare’s purpose is not SSL, they do offer SSL because they have to offer it to encrypt the first connection, but you are still responsible for the second connection.

If you want a secure connection you need a certificate on your server.

0 Likes

#16

I totally understand your point how only the first leg of the connection is secure and not the second one since my server does not have SSL. That is sort of fine by me only if it worked.

Interestingly I can still access my sites wp-admin over https just fine. It’s just that the content pages give 521 error

0 Likes

#17

Flexible (the mode that you describe) is not recommended as @sandro mentioned earlier, it can also cause errors and has more issues, I find! I agree that all hosts should allow you to install your own SSL for free and if they don’t, then you should consider switching.

1 Like

#18

Thank you domjh, I ended up removing SSL altogether and now it is working on http. I plan on moving to a different hosting plan now. goDaddy is the worst anyways.

1 Like