Error 521 - Can't figure out why

I’m trying to host a webserver using nginx on a Raspberry Pi.
I can access my website when going directly to my IP, but not through cloudflare ssl.
I’ve checked the access logs for nginx and there is no mention of any activity from cloudflare.
I have tried hosting through the router and IP that hosts my other website and I get a 522 from that.
Cloudflares ip adresses are whitelisted with iptables.

Can you connect when the host is :grey: in DNS?

Yes. Works just as expected.

On 80 and or 443? What is your SSL setting set to and what scheme are you using to connect http or https?

443, 80 is blocked by my ISP.
Connecting using HTTPS.
SSL is set to full, I have tried flexible.

I honestly don’t know why this fixed the problem, but I changed the IP in cloudflare for this site to the IP for my other website (which worked as expected).
When I changed it back to the IP for the raspberry pi’s site it started working for some reason.
I’m glad it works now but I don’t like the fact that I don’t know why it started working :thinking:
Yes, the IP was typed correctly before I changed it.

This topic was automatically closed after 31 days. New replies are no longer allowed.