Error 521 but works when CF is disabled


I have been using CF for a while now but on a new site that I set up, I am receiving 521 errors repeatedly on pages. As soon as I refresh the page, however, it works. Whenever I click on a menu item, it gives a 521. I refresh it and it works, but as soon as I click another link, I get a 521.

I have contacted my host and they say that the server logs do not show any errors that could cause it and don’t think the traffic is getting as far as the server, not sure why it works every time as soon as you refresh though…

The site works fine when I disable CF but receive these errors as soon as I enable it.

I have had to temporarily pause site on CF and use Let’s Encrypt cert until this problem can be sorted.

Any suggestions?

Check If Cloudflare IPs are blocked and ask your host If there are any rate limits configured.

More troubleshooting tips:

1 Like

Thanks @MarkMeyer

Host says:
As far as we can tell the Cloudflare Ips are not blocked and no we do not rate limit.

Would you mind telling us the domain?

@MarkMeyer CF is currently disabled but I can re-enable it if needed for troubleshooting.

it is:


Thanks for your help @MarkMeyer. My host has whitelisted the CF IPs listed at on the server and it seems to have worked.

You’re Welcome
Happy to read it’s solved. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.