Error 521 after changing the Host

Hi CloudFlare Community,
48 hours ago I have changed the Host

The first thing I have done is moved the files to the new hosting then imported the database etc…
I have done all of that on a testing Domain that is pointed to Cloudflare and using the new host, to make sure that everything is working fine before moving it to the new domain.

Second, I replaced the IP of my main domain in CL DNS with the new hosting IP.

it started showing me error Error 521, I did some searches before posting this topic but it seems that I have done everything correctly.

I have replaced the new IP in DNS records with the old one to connect to the old hosting and it worked.

-CP: VestaCP( ubuntu 18.04)
-Main Domain: GamingForum.to

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

1 Like

Hi sdayman, Thank you for replying to the topic, I have tried what u told me but it didn’t work.

I forget to mention that The forum domain is on Cloudflare for almost 11 months so there is a lot of data on Cloudflare.

Do u have another solution?

also, I can share my screen on discord if u are free for 2-5 mins({redacted})

If Pausing Cloudflare doesn’t fix it, you need to have you host check, as Cloudflare is out of the picture once it’s Paused.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.