Error 521 after activation of HTTPS

Hello,

I have a ERR 521 problem right after HTTPS activation on my website.
Before the activation of HTTPS, the website works fine, I just have a non secure connection at the URL bar.
But after getting the HTTPS to work on the website, I get Error 521.
As you can see, the website is just fine, running on Wordpress, PhP 7.4:

http://http://158.69.59.206/ is just fine.
Any clue on what’s causing this error?

Many thanks!

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Thank you for your reply.

I used to have Cloudflare redirect the domain name to my website and to have Https working without a problem. The only change I made is that my website was mograted from Debian 8 to Ubuntu 21.04, and nothing else changed (same Ip for the VPS, same hosting provider).
I already did some manipulations like paude Cloudflare and remove it and put it again but nothing changes, as soon as Https becomes active, I have Error 521.

Could you please advise what does “then make sure site is working as expected with HTTPS” mean?

It means that when Cloudflare is paused, your site should still work with HTTPS.

Actually I always had HTTPS working through Cloudflare, and never installed a SSL certificate for it to work with Cloudflare, somehow Cloudflare managed to do it for my website. Is it a new policy?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.