Error 520, Web server is returning an unknown error

I need help, my laravel application sometimes returns error 520, web server is returning an unknown error, I’m using Ubuntu server 18 on a Vultr VPS, with LAMP on PHP 7.1.

I am sorry to hear that you are having some issues.

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

Due to the SSL, may I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Regarding available SSL options at Cloudflare dashboard, check here:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Maybe your Web app based on Laravel CMS is working on some other port which is not compatible & supported with Cloudflare :orange: (proxy mode)?

Does Laravel work over the HTTPS?

Ports list compatible and supported when using :orange: cloud (proxy mode) on Cloudflare can be found here:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.