Error 520 on one device

Greetings. I have been having problems using the “bet365” application for about 1 week, and in some sections the Cloudflare 520 error also appears, I have already contacted the site’s assistance and they say they can’t do anything (in my opinion they don’t know how do and they don’t understand what is the problem since they just tell me to reinstall the app, clear cache etc. I tried to explain to them that probably my device has been locked), but this problem only happens to me on one device so I think my device has been blocked. Can you help me find a solution? If the only way is to contact the site, can you tell me what I need to tell them so they understand how to fix it? This is the message at the bottom of the "What happened?
There is an unknown connection issue between Cloudflare and the origin web server. As a result, the web page cannot be displayed.

What can I do?
If you are a visitor of this website:
Please try again in a few minutes.

If you are the owner of this website:
There is an issue between Cloudflare’s cache and your origin web server. Cloudflare monitors for these errors and automatically investigates the cause. To help support the investigation, you can pull the corresponding error log from your web server and submit it to our support team. Please include the Ray ID (which is at the bottom of this error page). Additional troubleshooting resources.

Cloudflare Ray ID: 7bd72354f975a25e
Your IP: hidden
Performance & security by Cloudflare"

Hello @gianlucamucciolo2012 ,

I’ve responded to the ticket that you’ve created.

I am not seeing any active domain under your account.
Kindly respond to the ticket using the email account that has access to the domain.

Also kindly share the domain in the ticket if there’s multiple domains under that account.

You may also want to take a look at the following link for 520 error:

I am not the owner of a domain, but I am a user

Did this ever get sorted I’m having the same issue

Someone solved? I’ve got the same problem and I don’t know how to solve, tried everything and the site’s assistance said that they can’t do anything about that.