ERROR 520 just keeps showing up

I’ve been getting this problem for at least 4 days now. I have contacted my hosting provider but they told me the issue was to blame on CF.

I’m a total noob in terms of website development and have no clue about coding. I also noticed this is an issue for many others as well.

I have “tried” all of the tips that CF suggests to resolve 520 ERRORS but without success.

I also opened a ticket to get a bot response back that wasn’t really helpful since it redirected me to the same CF page that included the “fixes”.

Is there a solution? Will there be a solution? Or should I leave CF?

This issue has been a huge pain. Organic traffic has decreased SIGNIFICANTLY, my audience just keeps asking what is going on, and I’m also not making a good impression on all my potential clients in the midst of a Social Media promotion that I’m running. Help Cloudflare :unamused:

I am also facing the same issue for the past 3 to 4 days with it really affecting my organic reach and potential clientele.

I may be a complete noob in terms of coding and website development but I saw you were all talking about disabling HTTP/2. I’m on a free plan so I can’t disable it.

That’s why I tried disabling HTTP/3 (with QUIC) which is directly under HTTP/2.

The issue seems to be resolved for me. I tried it out a good amount of times and it seems to work. Whenever it is enabled it returns the error, but whenever I disable it I don’t get it even after refreshing the page multiple times.

I’ll keep you posted guys. Please don’t roast me, I really don’t know anything about this stuff :sweat_smile:

We were referring to your server’s HTTP/2 support.

1 Like

Hey, I am also facing the same issue for the past 3 to 4 days with it really affecting my organic reach and potential clientele.

I may be a complete noob in terms of coding and website development but I saw you were all talking about disabling HTTP/2. I’m on a free plan so I can’t disable it.

That’s why I tried disabling HTTP/3 (with QUIC) which is directly under HTTP/2.

The issue seems to be resolved for me. I tried it out a good amount of times and it seems to work. Whenever it is enabled it returns the error, but whenever I disable it I don’t get it even after refreshing the page multiple times.

Please don’t roast me, I really don’t know anything about this stuff :sweat_smile:

1 Like

In fact the talk was about disabling HTTP/2 on your origin server, not on Cloudflare.

That’s interesting, will try!

The Directadmin “solution” just bypasses Cloudflare. It does not fix the 520 error.

1 Like

Hi @eliaskon20,

Due to the number of 520s being reported in similar circumstances, we are escalating the issue to Cloudflare Support. The original incident should have been resolved and your issue may well be unrelated.

We recommend checking these troubleshooting tips, if you haven’t already.

If you have been through these thoroughly and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that #.

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • Ray IDs from the 520 pages
  • output from a traceroute from any impacted user
  • output of example.com/cdn-cgi/trace - replace example.com with the affected domain.
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare ?
2 Likes

Ticket #2248305
Example URL: https://footxfit.com/links/
Ray ID: 68a5f2bc3b889e61
fl=88f43
h=footxfit.com
ip=46.177.198.2
ts=1630913011.16
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.159 Safari/537.36
colo=ATH
http=http/2
loc=GR
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

Ticket #2247947

It’s cold comfort, but my site visitors are seeing far, far less 520s today than earlier this week.

Reports are between 0 and 3 today (I’ve seen 2 so far). At this point, it’s more an annoyance than urgent problem. I’m going to think happy thoughts and assume it’s a Cloudflare problem that’s being addressed and someday [soon?], the errors will dwindle down to zero. :sweat_smile: In the meantime, I’ve closed my ticket as “Solved”, as I doubt any further diagnostic information I provide will help.

Tip: Check the Coverage section of Google Search Console; if there’s a noteworthy problem with site access, the chart will usually show how many pages are failing on a given day and give example URLs. For example, if my site was throwing HTTP 500 or 503 errors, they’ll be listed, typically within 24 hours.

Oddly enough, for the entirety of the period I’ve received visitor reports of 520s, GSC is showing zero errors. Of course, that could be the Cloudflare CDN the access is going through is (or is not) having problems, but it also suggests that the problem is not widespread, otherwise Googlebot would squawk.

1 Like

So as part of https://community.cloudflare.com/t/random-520-errors/ we fixed an issue with origins silently ending a keepalive connection that was causing very rare 520 errors.

Thus we recommend testing again - if you still see 520s - make sure you follow the guidance in our community tip here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.