Error 520 Issue

Issues comes and goes. I’ve gone through the quick fix ideas.

  1. Check web server error logs
  • I don’t know how to find the error logs
  1. Your web server returned an invalid response that exceeded our limits.
  • The headers haven’t changed in the past week or so, and this issue only started showing up yesterday (Cloudflare has been hosting the site for over a year)
    1. While you’re having a conversation with your hosting provider, make sure they include on their allowed list.
  • Hosting provider is not providing any security so there isn’t an allowed list.
  1. While the 520 error can be triggered by unique and seemingly strange edge-case scenarios, they are generally caused by: Connection resets (following a successful TCP handshake), Headers exceed the Cloudflare header size limit (over 8kb), An empty response from origin, An invalid HTTP response, Missing response headers from an HTTP response, or the Presence of multiple Content-Length headers.
  • … okay… so what do I do?
  1. Note that if Always Online is enabled, this error will trigger to be served.
  • I disabled Always Online and tried again in cognito mode and still had the Error 520 issue.
  1. Ray ID: 7022561ba2937bf8

fl=12f726
h=solaredgepros.com
ip=70.115.104.22
ts=1651008366.127
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36
colo=LAX
http=http/2
loc=US
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off

Thanks for any help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.