Error 520 in Joomla admin

Deleting the cache or deleting records is not the problem, the problem is that after that I get an error 520. When I refresh the screen, the error is gone. But it is annoying that I see that error 520 every time.

How exactly can I imagine your setup? Do you have Cloudflare connect directly to your server or are there any additional proxies, of yours, in-between Cloudflare and your actual origin?

The website is hosted by a service provider and connected directly to Cloudflare. I don’t have any proxy installed. But I don’t know or the provider uses any proxy.
I also asked them to have a look at the problem.

Could you try temporarily disabling HTTP 2 on your server? I’d be curious if that might just fix it.

Which error log did you find this error message from? I’m having similar issue with intermittent 520 errors in both joomla frontend and backend.

@mark36, same HTTP 2 advice for you.

I really don’t know how I can disable HTTP 2, but I will ask my provider if they can do that :blush:

[Thu Sep 02 16:52:03.641211 2021] [lsapi:error] [pid 3870398:tid 139661802080000] [client 172.69.62.80:11274] [host zoo-educatie.nl] Error on sending request(GET /?Itemid=2179 HTTP/2.0); uri(/?Itemid=2179) content-length(0): ReceiveAckHdr: nothing to read from backend (LVE ID 1384), check http://docs.cloudlinux.com/mod_lsapi_troubleshooting.html

The problem is still there. I asked my provider to see if they can make some changes. If that doesn’t help, I think I have to stop using Cloudflare.

Well, did you try and disable HTTP 2?

No, I don’t know how to disable it, so I asked the provider of my websites. But until now they did not respond. So I just have to wait :blush:

That’s the important bit. Somehow I assume it could be about HTTP 2 and if you could disable that and the error does not occur any more, then we’d know what needs fixing.

2 Likes

Hi,

I text you tmr, I know how to disable http/2, don’t give up using cloudflare,

Good night :slight_smile:

I received an answer from my provider. Because I have a shared hosting account, they can’t just disable HTTP 2.
They advised me to test another PHP version. At the moment, I use PHP 7.4. I tried PHP 7.3 but the template I use in Joomla is not compatible with that version. Then I tried PHP 8.0 but then a part of my WordPress website did not work anymore.
The next step I took is pausing Cloudflare. Now I don’t get any 520 errors anymore and surprisingly the backend of Joomla is much faster.

you can add the following to the sites .htaccees file to stop HTTP/2:-

RewriteCond %{SERVER_PROTOCOL} ^HTTP/2.0$ [NC]
RewriteRule . [F,L]

Hi @rob.de.ruiter,

Due to the number of 520s being reported in similar circumstances, we are escalating the issue to Cloudflare Support. The original incident should have been resolved and your issue may well be unrelated.

We recommend checking these troubleshooting tips, if you haven’t already.

If you have been through these thoroughly and are not seeing corresponding issues on your network/server and you have a ticket number with Cloudflare, please reply and post that #.

To enable efficient troubleshooting by support, please ensure you include the following on the ticket:

  • example URL(s) where you are seeing the error
  • Ray IDs from the 520 pages
  • output from a traceroute from any impacted user
  • output of example.com/cdn-cgi/trace - replace example.com with the affected domain.
  • Also include two HAR file(s) : one detailing your request with Cloudflare enabled on your website and the other with Cloudflare temporarily disabled - see How do I temporarily deactivate Cloudflare ?
2 Likes

Since I have a free account, I think I cannot open a ticket at Cloudflare Support.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you cannot login or can’t access the ticket flow, email [email protected] from the email address on your account. If you receive an automatic response that does not help resolve your issue, reply and indicate that you still require assistance. And, please share your ticket number here so that we can track it.

1 Like

So as part of https://community.cloudflare.com/t/random-520-errors/ we fixed an issue with origins silently ending a keepalive connection that was causing very rare 520 errors.

Thus we recommend testing again - if you still see 520s - make sure you follow the guidance given by @sandro and others to troubleshoot your origin server.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.