Error 520 cloudflare server not pointing to my hosts server

Hi everyone. I have a wordpress website, but when i search for it “Error 520” appears. I contacted my host and they told me that cloudflares servers aren’t pointing to their servers (host :bluehost) I’ve already input the 2 domain names that cloudflare requires me to do.
Please help me, thanks.

Can you share the name of the domain?

(post withdrawn by author, will be automatically deleted in 1 hour unless flagged)

Is that supposed to be your site?

yeah, that’s the construction page. But i think that’s an offline version of it, because it won’t even allow me to do a speed test on cloudflare and that construction page doesn’t appear on mobile. This appears when i tried to do the speed test:

The Speed test could not run.

insightcaptured.com returned a status 520. Try the options below to fix the issue.

1

Review the configuration between your origin server and Cloudflare and ensure that the origin resolves requests successfully

2

Review any existing Firewall Rules applied to your website which may be blocking access to ‘Known Bots’

3

Contact [Customer Support]

I guess you have the wrong IP address configured on Cloudflare. Does it end in 145?

Which name must i look? and by DNS? i don’t see any 145 in DNS

In your DNS control panel on Cloudflare.

type: A name: “sitename” content: .145 TTL: auto proxy status: proxied

That’s where i have an ip ending with 145.

That should probably be an address ending in 104 instead. If you dont know the full address you can either contact your host or I can post it here too, if you are comfortable with me posting it.

sure you can post it here, i’m not really educated too much on how servers work. Fairly new to the scene, so don’t know how much could go wrong

As far as I can tell x.x.x.x should be the correct address. You still might want to confirm this with your host though.

i have that one already, it’s right above the one i described earlier. They’re exactly the same, but with different ip’s

In that case I would suggest you remove the 145. But you really might want to clarify this with your host.

what should i ask exactly? Because they told me that cloudflares servers aren’t pointing to theirs. I have an idea of what that means, but not clue how to fix something like that

Which IP address(es) you should configure. You could also simply try and remove the one in question and only keep the other one. I guess it should work, but whether everything will work (e.g. mail) is a different question. For some reason your DNS configuration is broken and you need to fix that, but only your host can tell you which records are proper.

You could also remove the domain from Cloudflare altogether, switch back to your host’s nameservers, and start the setup from scratch. At that might Cloudflare should hopefully import everything correctly.

thanks for your help, i’ll try it out.

i’m talking to them right now and they said this If you want to host website with us. The domain should be pointed to .104 ip.
The Error 520 is on the cloudflare end. You need to point domain to .104 ip so that website pulls contents from our server

Ok it’s working now i had to delete the .145 in the control panel. Is there something else i should need to worry about like mail etc? I mean it’s weird that, that DNS was there.

Mail is something you need to try out. It is best you clarify your entire DNS settings with your host.