Error 502: When accessing web server

ZERO TRUST TUNNELS

pve.branryl.xyz
https://192.168.2.150:8006

When I go to my proxmox server on the IP it works.
when i use the domain name I get error code 502 Bad Gateway.

Error log:
{
“originService”: “https://192.168.2.150:8006”,
“ingressRule”: 0,
“error”: “Unable to reach the origin service. The service may be down or it may not be responding to traffic from cloudflared: dial tcp 192.168.2.150:8006: connect: connection refused”,
“connIndex”: 1
}

No have NoTLSVerify turned on.

It was working a while ago and then just stopped working one day.

Does not work in Brave. I have also tried private mode.

I have tried setting httpHostHeader to 192.168.2.150:8006

cloudflared version 2024.2.1

NOTE: cloudflared is running on my proxmox server as an LXC but that should not matter.

From the host running cloudflared, can you curl the URL successfully?

A post was split to a new topic: 502 on Tunnel while IP:port still works

Command used: curl 192.168.2.150:8006

response: curl: (7) Failed to connect to 192.168.2.150 port 8006 after 0 ms: Couldn't connect to server

I also have another server that I will need to get working. It is Pi-Hole and it is an http server giving me the same 502. But don’t worry about it right now because I can get it working later.

Also running curl 192.168.2.2:80 (Which is my pi-hole server) gives me the webpage that pi-hole displays, but still gives me 502 Error.

My tunnel is also now saying as a status “DEGRADED” which it was not saying the issue started

If you fix this then it should work.

What does the cloudflared error log so for this?

Error: Request Failed
{
“connIndex”: 1,
“originService”: “http://192.169.2.2”,
“ingressRule”: 1,
“error”: “Unable to reach the origin service. The service may be down or it may not be responding to traffic from cloudflared: dial tcp 192.169.2.2:80: i/o timeout”
}

BTW my tunnel is back to healthy

I can do this myself but as a starting point what do you think would be causing this, because keep in mind that the cloudflared host in running on the same computer as “192.168.2.150”. I’m thinking firewall but what do you think?

It looks like you typoed your origin service. Guessing this should be http://192.168.2.2

It could be the firewall. If it is on the same host, then there might be something weird about it accessing the interface that has 192.168.2.150

Ok so I fixed the 192.168.2.2 server. I can’t find anything about how to disable linux firewall because it says firewalld.service could not be found and if it was not the firewall what could it be