Error 502 after SSL setup


#1

Hi, my website is www.exsportyhub.com

  1. I have changed the nameservers from NameCheap to Cloud Flare. The SSL is active but not showing the https.
  2. Error 502 happens. My host provider, Linode confirms that everything is OK from their end.
  3. I have been trying to contact Cloud Flare support team with regards to these problems but no answer so far. It has been few days.
  4. Appreciate if anyone here could assist me to fix these problems.
  5. P/S: I’m a beginner in this field.

#2

The first response I get is a 521 (Web server is down). Then it refreshes and turns into a 502.

Did you install SSL on your Linode server?

What SSL setting are you using at Cloudflare?

My theory is you don’t have SSL on your Linode server, so it’s not listening on Port 443. You have Cloudflare SSL set to Full, so it’s trying to reach your server on Port 443, and can’t. Then it fails in various ways.

Try: Setting Cloudflare SSL to Flexible.


#3

Hi there,

I installed SSL setting on NameCheap.

“Make sure Cloudflare is set up to point to 139.162.13.204” this was Linode’s response when I checked with them.

How do I go about changing the setting SSL to flexible?


#4

I don’t think the SSL setting on Namecheap takes effect on your Linode server. At this point, Namecheap’s only part in this is to tell the world to use Cloudflare when trying to reach your domain.

At this point, it doesn’t seem your server is listening on port 80 (http) or port 443 (https). i.e. your web server isn’t running. I can ping it, but can’t reach it on Port 80 or Port 443.

Two things to try:

  1. In Cloudflare’s DNS settings, change your domain records from :orange: to :grey:. This will restore direct connectivity to your server. My guess is this isn’t going to work since I can’t reach it directly anyway.
  2. Change your name servers back to NameCheap and see if your site is working. This takes Cloudflare completely out of the equation. Again, I don’t think this is going to work for the same reason as above.

#5
  1. I have tried to change as per your suggestion #1 and the site couldn’t be reached at all. Now I’m changing back to its previous setting, and still stie couldn’t be reached.

  2. I have temporarily deactivate the Cloud Flare but the site still couldn’t be reached.

What should I do now? Please assist. Thx.


#6

For www.exsportyhub.com is showing error 512 & 502

For http://exsportyhub.com site can’t be reached.


#7

It’s quite likely your web server (Apache or NGINX) isn’t running on your server. Try rebooting it. If that doesn’t work, you’ll have to troubleshoot it…or rebuild the server in an easier-to-maintain configuration.

A solid server setup would be to use Ubuntu 18.04 on your server, and have Serverpilot.io install a web server configuration. Their free plan is very reliable. It doesn’t feature SSL, but that can be installed manually.


#8

HI,

I have finally fixed this problem by migrating to cloud based server by Bluehost.

I’m trying to optimise my website page speed by configure to Cloud Flare CDN.

My question is, since I’m already on cloud based server with Bluehost, do I still need to setup to CDN with CloudFlare in order for me to optimise my website page speed?

Thanks.


#9

I have the same problem here https://www.goztepetemizlik.com.tr/ in my blog. And unfortunately cooud’nt find any solvation


#10

That domain isn’t using Cloudflare. But it’s working. It doesn’t work when you switch to Cloudflare?


#11

Thank you for the reply ı have swiched to cloudflare but after the error ı deleted cloudfare till ı find some one who can help me sut it up again.


#12

This topic was automatically closed after 14 days. New replies are no longer allowed.