Error 502 after creating via Dashboard

I created a tunnel using the dashboard and it is connected. I added a public host name for a domain on Cloudflare. It automatically added the sub domain with the target being uuid. cfargotunnel. net in the DNS records.

Now when I hit the tunnel I get the 502 error. But pinging the uuid. cfargotunnel. net address gives me an unresolved host. So not sure if that’s the issue.

I can ping the tunnel by subdomain. domain. com which resolves to a Cloudflare ip (this is the subdomain used for the tunnel).

From what I read it seems like 502 is at the device level. But it shows tunnel is connected. I even turned off the windows firewall. The public hostname is simply hosting https localhost which works fine on this box itself.

Details of the box that it’s being a CGNAT router which I don’t think should be an issue since when I tested ngrok on it, worked just fine.

Well I just figured it out. Turns out I needed to enable the disable TLS verify in additional settings.