Error 500 - Internal Server Error with Argo Tunnel

Hello, I’ve been getting error 500 - Internal Server Error with argo tunnel.
I’ve determined that my server & connection is OK by:

  • connecting directly (LAN) to it and do web request
  • connecting with different ISPs
  • connecting through normal cloudflare proxy DNS
  • turning off firewall
  • checking packet drop and there seems none

When tried with cloudflared tunnel, I get 500 - internal server error consistently by just keep refreshing the web page until it appear.

I’ve run cloudflared with debug:
cloudflared tunnel --loglevel debug --transport-loglevel debug --logfile cf.log run

and monitor the request, when 500 error occurs, there seems no matching ray on the log. I’m unsure
if the request packet arrived or not.

I also tried with cloudflared tunnel run -p http2 and got same results.

This is response header for the 500

alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400
cache-control: private, no-store
cf-cache-status: DYNAMIC
cf-ray: 64a624132cc8d1b3-HKG
cf-request-id: 09dbb4dff70000d1b3a6b74000000001
content-length: 0
date: Wed, 05 May 2021 01:19:29 GMT
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
nel: {"max_age":604800,"report_to":"cf-nel"}
report-to: {"max_age":604800,"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=CIEP5xyLIggsypalTohlPGOfFe3r2mBnLMBql325XrYtv7lNi4gxxGbAnEezd3RyVGmOaHa0rVupQTlbKhnLLHMk4DmIjuia2UrPQtg53C%2BlfVnDIxIAxpJoklU%3D"}],"group":"cf-nel"}
server: cloudflare
vary: Accept-Encoding

My config:

tunnel: 16c0bb38-7d14-4304-bf4c-xxxxxxxxxxxx
credentials-file: /home/redacted/.cloudflared/16c0bb38-7d14-4304-bf4c-xxxxxxxxxxxx.json
metrics: 192.168.1.230:8099

ingress:
  - hostname: hostname.com
    service: https://localhost
    originRequest:
      noTLSVerify: true
      disableChunkedEncoding: tested both true & false
  - service: http://localhost

Normal output of cloudflared tunnel run

2021-05-05T01:32:23Z INF Starting tunnel tunnelID=16c0bb38-7d14-4304-bf4c-xxxxxxxxxxxx
2021-05-05T01:32:23Z INF Version 2021.4.0
2021-05-05T01:32:23Z INF GOOS: linux, GOVersion: devel +11087322f8 Fri Nov 13 03:04:52 2020 +0100, GoArch: amd64
2021-05-05T01:32:23Z INF Settings: map[cred-file:/home/redacted/.cloudflared/16c0bb38-7d14-4304-bf4c-3394b6788c2f.json credentials-file:/home/redacted/.cloudflare]
2021-05-05T01:32:23Z INF cloudflared will not automatically update when run from the shell. To enable auto-updates, run cloudflared as a service: https://developers.clo/
2021-05-05T01:32:23Z INF Generated Connector ID: 9b58b5fc-cd69-45ee-ad9c-41ab115250eb
2021-05-05T01:32:23Z INF Initial protocol h2mux
2021-05-05T01:32:23Z INF Starting metrics server on 192.168.1.230:8099/metrics
2021-05-05T01:32:24Z INF Connection 9658ba66-a149-48bc-a9ac-feb9cd29d2e0 registered connIndex=0 location=SIN
2021-05-05T01:32:25Z INF Connection 23fa1f4a-5e4f-41cb-9e8f-a800b0a6262e registered connIndex=1 location=HKG
2021-05-05T01:32:26Z INF Connection 6b340eca-0a70-4096-8db1-d32d63a65bac registered connIndex=2 location=SIN
2021-05-05T01:32:27Z INF Connection e02e5492-f6ef-49e9-ac0a-322a55535a24 registered connIndex=3 location=HKG

Thanks

1 Like

I don’t expect this will get much of a response here. Have you opened a ticket? If so, please post the ticket # to make sure it gets to the right people.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

I’ve opened the ticket: #2149487

1 Like

Thanks so much for this, I was running into Argo Tunnel’d sites throwing 500 errors all over the place the past few days. Bypassing the proxy/using the traditional inbound Cloudflare proxy continued to work no problem so the issue was definitely Argo Tunnel.

It looks like this was fixed some time yesterday. I switched back to the Argo Tunnel connection and haven’t seen any 500 errors since yesterday.

yes, I can confirm too that the issue disappeared without doing anything.

Would love to get an update from Cloudflare on what happened. I have been tearing my hairs out for a couple of days know trying to understand what was happening. Didn’t even occur to me to raise a ticket (because I am on the Free plan and all). Glad to see it’s resolved. Reverted back to Argo Tunnel connections and see if it is indeed stabilized.