Error 404 - Page not found error

Hi guys, my website is suddenly inaccessible, whenever i try to reach it this is the error i get

Page not found (404)

Request Method: GET
Request URL:

Using the URLconf defined in gt_api.urls , Django tried these URL patterns, in this order:

  1. ^admin/
  2. apiDocs/
  3. ^api/
  4. api-auth/

The empty path didn’t match any of these.

You’re seeing this error because you have DEBUG = True in your Django settings file. Change that to False , and Django will display a standard 404 page.

can anyone offer any help?

Hi @geotraveltech,

Can you try pausing Cloudflare in the site to see if the issue remains?

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

If the issue persist after Cloudflare has been paused, it means that there is an issue with your origin, Cloudflare is only operating as your DNS provider while it is paused.

Hello @domjh

Thank you for your help

I tried this and tried visiting the site again, still the same

My origin if you mean web hosting is the AWS EC2

They have claimed all instances, lightrail and services are working fine

I do not understand what exactly is wrong

Thanks again for your help

Right now requests go straight to your Amazon server and it still returns a 404. That is a local issue on your server I am afraid.

1 Like

Hello @sandro

By issue on local server, do you mean the same AWS EC2 host?

Yes, precisely that.

Thank you @sandro

The other issue is that, another website (a subdomain of the main website) hosted on the same platform returns another error

If you are the owner of this website, please contact your hosting provider: [email protected]

It is possible you have reached this page because:
i. The IP address has changed.
ii. There has been a server misconfiguration.
iii. The site may have moved to a different server.

That record does not seem to exist in the first place. You need to create it on Cloudflare first, but be aware that you wont be able to use it with HTTPS, unless you purchase a dedicated $10/month certificate from Cloudflare.

Only exists. And if that doesnt work it still is a server issue. You need to fix your server.

Do you also think changing the nameservers from cloudflare back to the one provided by the hosts could help?

Very unlikely. The issue is not DNS, but the server simply returns these errors.

Thank you @sandro, I will have to reach them again

This topic was automatically closed after 14 days. New replies are no longer allowed.