Error 404 after setting up Cloudflare and migrate my DNS

Hi guys,

I have a domain with Namecheap, and a site hosted on Bluehost. I have decided to add my domain to Cloudflare and manage my DNS from there. However, I am getting a 404 error when proxied the A and cname records. SSL certificate is added from the Bluehost side. Once I disable the proxy on the A and CNAME records the site is operational, but I want to take advantage of Cloudflare features by enabling the proxy.

A record:
mydomaindotcom ------ IP address of Bluehost

CNAME:
www ------- mydomaindotcom

Any suggestion on how to solve this, please?

what is the actual domain name? example dot com is fine

flashmerce dot com

1 Like

Please, anyone can point me in some direction regarding this? I am not sure if it’s a Cloudflare configuration issue or is on the hosting provider side.

Something is cached here:
cf-cache-status: HIT

Can you temporary enable the “Pause Cloudflare for this site” option from the bottom-right corner of the CF dashboard → Overview? :thinking:

Hi,
Thanks for your reply. I already did that (Pause Cloudflare for this site) and had to set up my domain back on my original registrar and it works. Also if I disable the proxy on my A record works as well and I even can see on the mxtoolbox that Cloudflare was the DNS provider. The issue only happens when I enable the proxy on my A record, I can reach my website (error 404).

In the first attached image Bluehost (hosting provider) says that A records are not pointing to Bluehost. I obviously have my A record (proxied on Cloudflare) pointing to that IP (50.87.X.X).

Also attached is a second image from my browser network tab logs in case you can see something I don’t.

Reading the Bluehost documentation about Cloudflare I saw this but I am not sure that I have understood it very well the sentence or if it has anything to do with this problem:

You have to setup SSL for your domain BEFORE turn on Cloudflare for your domain

Hi, I do have SSL enabled on my origin server. I am also using the Full option on Cloudflare.


Still not working.

To make sure the correct error is found, please follow these steps
1, Turn off Cloudflare’s proxy for both records as root domain and www.domain
2, Visit the website to see if it works?
2.1, If not, need to check if it is pointing to the server’s IP address correctly?
2.2. If it’s working properly, re-enable Cloudflare’s proxy
3, After re-enable Cloudflare proxied, purge Cloudflare cache, change Browser Cache TTL to 5 minutes to test, enable development mode

I suspect that you are not pointing to bluehost’s host IP address correctly.

Here is another similar topic about how to point to bluehost hosting, take a look

Hi huyhoa,

First of all, I really appreciate your help and the help of all those who have taken the time to review this topic and tried to help me.

I did not have a chance to test this yesterday. I did it today. Here is the result:
1-2. I have already done this a few days ago and without proxy enabled it works fine.
3. I purged Cloudflare cache, changed Browser Cache TTL to 5 minutes to test, and enabled development mode as you suggested, unfortunately, did not work.

I suspect that you are not pointing to Bluehost’s host IP address correctly.

I am pretty sure (I have checked a dozen times so that I am not making a typing error) that my A record on Cloudflare is pointing to my Bluehost’s shared IP (50.87.X.X)


Reading the topic you sent me I don’t think is the exact same issue but I did something @sdayman did and the result is this.

I am getting a 200 ok response with HTTPS, and I guess that the website is redirected from HTTP to HTTPS according to the second output.

I am still feeling very stuck on this. I need to solve this and fully understand what is happening.

Any reply guys? Still stuck on this weird issue. My website is not WordPress, but this is not a problem I assume.

If this is only an issue when :orange: Proxied, you may actually be proxying to another host.

Please read this, and pay close attention to the Liberate The Hostname part:

1 Like

Thank you very much @sdayman.

However the whole article refers to a change of provider, I have had my site on Bluehost since the beginning and it was created using a simple Page Builder (instead of using WordPress).
If you can give me specific instructions on what to ask Bluehost’s tech support, I would appreciate it.

Bluehost uses Cloudflare’s SSL for SaaS product. They added it when you first starting using Bluehost: it’s irrelevant whether you are using Cloudflare at that time or not.

The solution to this is to use the Liberate the Hostname option linked above. That will remove control of the proxy setting from Bluehost (you can still stay at Bluehost! :slightly_smiling_face:) and allow you to Proxy your A record at Cloudflare.

4 Likes

I believe it’s working now :smiley:. Thank you so much @mcfadyeni and @sdayman. Liberating the hostname actually did the trick. Your explanation @mcfadyeni helped me to understand better why I needed to do this process. Great lesson here

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.