Error 403 sitemap in google console

Hi
I have error 403 for sitemap in google console.

I read these topics:
https://community.cloudflare.com/search?q=sitemap%20403
and https://support.cloudflare.com/hc/en-us/articles/200169806-Troubleshooting-crawl-errors#h_788dc59a-6fcd-4fb0-95fe-83c8e6a169ff
But I cant find my answer.

1- When I disable cloudflare, the problem was solved and when I enable cloudflare, I see error 403 in google console.
2- I do not have any security plugins in WordPress.
3- I update SSL. The expiration time for ssl in 2035.
4- The sitemap open correctly and does not have any problem.
5- I do not block any IPs or user agent in firewall, robots.txt or cloudflare.
6- All permissions for files and folders are correctly.
7- I check firewall (Firewall Events) in cloudflare dashboard. I dont see any IPs to access sitemap path.
8- I tell this problem to my hosting support. They say we dont know what the problem for. Please resolved it with cloudflare support team.

Any body can help me?

1 Like

I think you need to further check your firewall events. Look for user agents similar to Googlebot.

2 Likes

In 2 weeks ago, All of them similar this:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.79 Safari/537.36

About 45 of them are:
agent: Wordpress
path: /xmlrpc.php
service: Browser integrity check

There is no google bot agent.

I see googlebot in this link:


So I allow googlebot and google.com in Firewall Rule in cloudflare but the problem doesnt solved:


But when I allow googlebot, they can access to sitemap:

But the problem is not solved.

Any body can help me?

I create a new rule in cloudflare firewall, but the problem doesnt solved:

Any body can help me?
Is this problem for my server?

This topic was automatically closed after 30 days. New replies are no longer allowed.