Error 403 in some images


#1

Hello,

My WordPress site has been worked with cloudflare for 2 years without problems. But I had to disable it last week because some images stop showing throwing 403 errors.

Any ideas?


#2

Can you post URLs? Do you also get a 403 when you try to open them directly? Maybe some hotlinking protection?


#3

Main site URL: https://futboldatosycuriosidades.com/ 2 images with 403

Link to one of the images: https://futboldatosycuriosidades.com/wp-content/uploads/2017/12/Fuera-de-juego-262x180.jpg

I checked hotlinking protection from cloudflare dashboard and it is disabled. Should I check elsewhere?


#4

Does the 403 have a Cloudflare branding?
If not, it’s your origin. Htaccess, IP deny and so on.


#5

Have you fixed it meanwhile? No 403s here now.


#6

No Cloudflare branding. But if I deactivate it, the images are displayed correctly

Cloudflare active = 403 error in 2 o 3 images
Cloudflare disabled = all images ok


#7

No, i just disabled Cloudflare again


#8

Well then it’s most likely a problem on your origin.

The top reasons for this error are:

  1. Permission rules you have set or an error in the .htaccess rules you have set.
  2. Mod_security rules.
  3. IP Deny rules

Since CloudFlare can not access your server directly, please contact your hosting provider for assistance with resolving 403 errors and fixing rules. You should make sure that CloudFlare’s IPs aren’t being blocked.


#9

Cant reproduce it, not a single 403 shows up. Could it be your IP is somewhere blocked?


#10

Mark You were right! Wordfence had blocked some ip’s from Cloudflare.

Can you please confirm if the site loads without errors 403?

I activate Cloudflare again


#11

Just a couple of 302 but nothing to be worried about.

https://www.webpagetest.org/result/180522_11_9bd1e9f6f0754226da13171cbefadf0d/

Click on the waterfalls for a detailed view.


#12

Thanks for your help!


#13

Welcome :slight_smile:


#14

Do you not “rewrite” the connecting (Cloudflare) IP addresses to the actual clients’ ones? If you do, Wordfence should not get them in the first place.

Again, I did not get 403s when your sites was behind Cloudflare.


#15

Hey Sandro. I whitelisted the ip’s and the site works correctly now.

Thanks for your help!


#16

This topic was automatically closed after 14 days. New replies are no longer allowed.