Error 1104 "Script not found", "What happened?"


#1

I am now getting Error 1104 while on CF, but only around 80% of the time. While off CF, everything works well. I have been unable to check RAY ID as advised in the error message because I don’t know how to on free CF.

Error 1104 Ray ID: 49164b937c4f35b4 • 2018-12-30 17:41:05 UTC
Script not found
What happened?

You’ve requested a page on a website (citroenc3owners.com) that is on the Cloudflare network. The script used to render this page could not be found.
What can I do?

If you are the owner of this website:
you should login to Cloudflare, check the error logs for citroenc3owners.com and verify your configuration.

Cloudflare Ray ID: 49164b937c4f35b4


#2

Haven’t seen that one before. Is this your website? It’s likely an issue with the website owner deleting one of their Cloudflare Workers scripts while keeping the route up, causing it to be unable to run.


#3

It’s possible it could be one of the Cloudflare Apps.


#4

Its one of the sites I look after. I have not seen it before and neither has google :wink:
There are no cloudflare workers for this one.

There are no CF Apps installed.

I have deleted the cloudflare entry and set it back up again but it still throws up this error.

For now the site if off CF, but I would like it back on again, sometime.

Thanks for the suggestions :slight_smile:


#5

!

Is there a big reset button I can press for the Cloudflare configuration?

Or is it possible to look into it via the Ray ID ? (I still haven’t worked out how to use these yet)


#6


#7

You can open a support ticket for it and they should be able to tell what the reason was.

That error message is a bit mysterious. Do you get it on the main page or somewhere inside the site? I can load the page without issues, but then you mentioned you only get it occasionally.

From the message I would usually not assume it to be a DNS issue, but do you have any particular DNS setup, anything pointing to a Cloudflare IP maybe?

@cloonan / @cscharff


#8

Probably due to:

It has a Let’s Encrypt cert at the moment.


#9

Excellent point :slight_smile:


#10

Thanks, I will raise a ticket with the Ray ID.

The site was unusable on CF, every page affected, but if I refreshed enough times, I could actually log on.

You are right, it is OFF CF because I tried it twice and each time the Error 1104 comes back.


#11

Do you have any firewall rules in place? Not sure if they run as a “script”. Maybe try enabling development mode and check whether it makes any difference. At this point it probably comes down to trial and error.

But that all is just random guessing. Best is probably to open the ticket and wait what they say and maybe @cloonan and/or @cscharff have an idea too. No proper idea I am afraid :confused:


#12

I am happy to do trial and error.

I think I will raise a ticket for the ray ID

Thank you all for your suggestions :slight_smile:


#13

No firewall rules


#14

No idea then, I am sorry. As far as I can tell you are the first to post that specific error here on the forum and search engines didnt reveal much about it either.

It seems you run quite a vanilla setup. Did you make any specific configuration changes after setting up the site, apart from the basic ones?

Did you check from different locations? Maybe specific to your PoP. Yes I am wildly speculating at this point :smile:


#15

Nope, just went via Cloudflare and got the same error too.


#16

Hang on, have you only disabled Cloudflare or have you switched nameservers altogether?

Right now you are not using Cloudflare nameservers. Are you possibly signed up to Cloudflare via a Cloudflare partner and not directly by yourself?


#17

I did a fair bit of searching before asking and that error is a new one.

The site has been on CF for years and I made some site updates and it all went pear shaped. I assumed it way may fault and double-checked my code changes until I started with cloudflare and when its OFF cloudlfare, everything works as expected.


#18

I am not using cloudflare at all right now. I don’t use CF nameservers now to get the site working.

If I use CF nameservers, even with a paused site, I get the error.


#19

:+1: :bowing_man:

Maybe some Cloudflare issue then. I think I reached the end of my speculation abilities now. Hand over to support :slight_smile:

Now that REALLY should not happen, as requests should bypass Cloudflare completely in that case and go straight for your server.


#20

No, there is no middle man, its me, CF and my host :slight_smile: