Error 1034 - Edge IP Restricted

We are getting the Error 1034 - Edge IP Restricted when trying to access our site.

Here’s what we tried, but didn’t work:

  1. Changed IPv4 to instead of the error message, we’re getting “Site is not available”.
  2. Purge Cache: we purged the cache, nothing happened.
  3. Used localhost IPv4: nothing changed.
  4. Tried different browsers: from Mocrosoft Edge, Chrome, and Safari, it never worked.

I kindly ask for help on this matter.


Thank you for asking.

I am sorry to hear you are experiencing an issue with 1034 Error.

When you switched to , was that hostname proxied :orange: or not?
Make sure it is proxied :orange:.

Set it to :orange: if you are using Workers or some similar configuration (like only Page Rules to redirect domain to another one).

And just in case, I would suggest you to add one more hostname, A www pointed to and proxied :orange: too.

I use both A and AAAA 100:: for naked domain and www (4 records in total) + using Page Rules to redirect non-www to www.

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?
→ Should be set to Full (Strict) SSL

Kindly, review the solution by following the instructions from the article below:

For more information, take a look on a recent topic related to this issue from below:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.