Error 1020 don't have any firewall rule

Now we are on 404?, if so, then it is not the same as 1020 error thrown by Cloudflare.
404 error comes directly from your origin host/server. I’d suggest you to re-check this with your hosting provider.

Before moving to Cloudflare, was your Website working over HTTPS connection?

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Nevertheless, you can check if your WordPress is configured to work over HTTPS using the below articles. Please, make sure your WordPress website (domain) is working over HTTPS, the WordPress admin too: