Error 1020 don't have any firewall rule

I’ve already read everything I can. I don’t have any firewall rule. And empty in the Firewall Events activity log.

When I pause Cloudflare, website is working.

I,m developer for website. no need to ask owner.

If all the above you mentioned, that’s a bit weird :thinking:

However, are you sure there aren’t being any Firewall Rules enabled (green toggle button) at the Firewall Rules list? :thinking:

If you still get 1020, you should see it and be able to find it by the “Ray ID” in last 30mins or so, therefore determine what blocked your request from accessing your Website.

  • it might appear a minute or two later, not immediately …

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?


I don’t have rules.
Yes i see “Ray ID”. but i don’t see nothing in activity log.
And yes, I tried different browser, clearing cache, on mobile phone. Still blocking.

When I change dns names nativ hosting (godaddy) everything is work. When i change dns names on Cloudflare, Cloudflare block access.

website: 10canada.ca

I think same problem
Error 404 - Page Not Found (No access to WP Admin) - DNS & Network - Cloudflare Community

move to godaddy back. i can’t understend why Cloudflare block access and do 404 for website after add to Cloudflare.

Now we are on 404?, if so, then it is not the same as 1020 error thrown by Cloudflare.
404 error comes directly from your origin host/server. I’d suggest you to re-check this with your hosting provider.

Before moving to Cloudflare, was your Website working over HTTPS connection?

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Nevertheless, you can check if your WordPress is configured to work over HTTPS using the below articles. Please, make sure your WordPress website (domain) is working over HTTPS, the WordPress admin too:

I use https. and I have ssl certificate

when 10canada.ca - error 404
10canada 404

when 10canada.ca/wp-login.php or wp-admin.php - error 1020

Godaddy very cunning. They give their certificate for free. Which works, as I understand it, only on their hosting. My other sites have paid rapid sll certificates and had no problems with Cloudflare.

In community hundred posts with problem.

Kindly, thank you for feedback information. I’ll re-check again if anything comes up as an idea for troubleshooting :thinking:

However, currently when I open 10canada.ca it loads fine from my end.
Therefore, 10canada.ca/wp-admin redirects successfully to wp-login.php at my end.
I assume it should be like that, but now I see you either have Paused Cloudflare for your website or set your records to unproxied :grey: (DNS-only), is that correct? :thinking:

May I ask if you’ve used some kind of a 3rd-party service, hosting partner or an Cloudflare integrator since before? Be it either like WPEngine, Shopify, eZoic …


now I enable Cloudflare. and website 404 error

1 Like

True, very interesting :thinking:

no, I don’t use 3-party service.

1 Like

Are you using Cloudflare Workers maybe and have some routes misconfigured?

That 404 error page is cached as far as I can see by the HTTP headers:
cf-cache-status: HIT

Have you tried Purging the Cache at Cloudflare dashboard → Caching → Configuration → there is a button “Purge Everything”? :thinking:

No fritex, i don’t use anything. default setting every where. Only change ssl to full strict

1 Like

I have to admit, it’s a bit weird behaviour :thinking:

Just in case, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and share the ticket number here with us in your next reply so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.