Error 1016 with Realm.mongodb.com (cloudflare worker)

Hi,

I’m using the MongoDB Realm web-sdk with a Cloudflare worker(similar to the tutorial) and it was working fine the past few this.

This morning, I kept receiving Status530 errors from the worker when trying to GET the realm app login page.

Upon further checking, Cloudflare Workers is giving an error 1016 with the message
“You’ve requested a page on a website (realm.mongodb.com) that is on the Cloudflare network. Cloudflare is currently unable to resolve your requested domain (realm.mongodb.com).”

Would anyone be able to advise please?

1 Like

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an 1016 error so far with your domain.

May I ask what is your domain name?

Did you used or do you use any of the possible Cloudflare third-party integration hosting provider / interfaces for your domain like Cloudways, SiteGround, etc.? (if the domain records are already at Cloudflare, but managed by some third-party if so)

Can you temporary use “Pause Cloudflare for this site” or switch the A or CNAME from :orange: to :grey: (DNS-only) if something changes?

  • Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  • The link is in the lower right corner of that page.
  • Give it five minutes to take effect, then make sure site is working as expected with HTTPS.

May I ask what have you tried so far from the suggestions from the article below due to this error?:

I am also getting the same error message 1016! I am using a Squarespace website and trying to redirect a subdomain using Cloudflare. Now my website is down and I don’t know how to fix it. It says there is a problem with the A name or the C name but I have no idea what it is. Please help!!!

Hi there! thanks for the reply.

strangely I was not using any domain, but purely the Cloudflare worker standard [app-id].[userid].workers.dev url.

Hence i had no control over the DNS settings for workers.dev.

it seems to be working now, perhaps there was a server issue on Cloudflare’s end?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.