Error 1016 Unable to create DNS A record

Hi yall, just to let everyone know I have no idea what I am doing. I have been trying to get Nextcloud up and running and trying to get it reverse proxied for over two weeks without any luck.

Here is my homelab setup
Hardware Dell Optiplex 3010
OS: 23.10 Truenas Scale
Using TrueCharts as the application installer
Homelab IP: 192.168.1.202
Nextcloud domain: nextcloud.MyDomanName

Router Configuration
Ports 80 and 443 are forwarded from 192.168.1.202

Problem
TrueCharts now requires Traefik to be installed as an ingress with every application including Nextcloud. It took me about a week to figure out how to install Nextcloud. It took me so long because all the guides are outdated and don’t work anymore. I spent my second week trying to open my newly installed Nextcloud but it kept giving me the error code 1000.

I don’t really understand networking at all but I did stumble upon DNS records. Because TrueCharts forces the use of Traefik, Nextcloud is forced to use the domain name instead of the homelab’s IP. So, I created a CNAME for nextcloud and now I get the error code 1016. In error 1016, it suggests that I have a DNS A record. So I proceeded to create one, but when I have the Proxy service on it gives me code 9004 (This record type cannot be proxied). However it does work when I have the proxy set to DNS only.

What I have tried

I think I have set up Truenas Scale correctly. I added the Cloudflare DNS (1.1.1.1) and added Clouflares certificates as well. Truenas Scale uses Docker to install applications, however it is almost impossible to fallow any docker guides, because Truenas is so different.

I have installed and set-up Cloudflared Tunnels and it is working

I tried to get cert-manager working on Scale, but I couldn’t figure it out. So I just used Scale’s built-in one.

I do not know if I have Traefik installed correctly I have done any configuring inside of Traefik all I have done is install it.

This is my Nexcloud Install on Truenas

Truenas Scale Network Interfaces

You can’t proxy a private/internal IP like 192.168 and even if you could Cloudflare’s edge would not be able to use it to connect to your private network as these IPs only mean anything within their local network.

You need to either port forward and use the public IP, or use Cloudflare Tunnel.

You can use that then, and set up a Public Hostname for it without this issue:

Please could you stop posting images of every single unrelated page from your TrueNAS setup? It would help make this thread a lot easier to read.

1 Like

Sorry for all the replies, but Cloudflare only allows new users to post one picture in a reply.

1 Like

No worries.

Perhaps in all that you missed my reply here:

Were you able to get it working?

Yes I have that set-up:

The cname on the domain is not pointing to the tunnel though.

And setting a hostname service to a public domain would cause an infinite reference.

Set the tunnel service to point to your local IP (192.168.1.202), then set the CNAME DNS record for the nextcloud subdomain to point to the tunnel ID in the form <tunnelid>.cfargotunnel.com:

So, like this?

Here is what my Tunnel page look like now.

I am still getting error 1016 when going to
nextcloud.mydomainname

This DNS record is not correct. Please review the guide again and follow format <tunnelid>.cfargotunnel.com:

Bonus tip: If you delete the existing DNS record and recreate the custom hostname from scratch, it will create your DNS record automatically.
Bonus tip x2: For the Public Hostname, if you are pointing https:// to a local IP you most likely want to select the SSL setting “No TLS Verify” so that it does not complain about certificates (this is fine when contained to a local private network). You can use http instead if the application allows for it.

Okay, that helped, but now I am getting error 1033.