Error 1016: Origin DNS error


FIrst off I don’t know anything about DNS, so I am curious if anyone can help me.

To speed up my website I wanted to implement Cloudflare. Hoping it will speed up my website. I followed the tutorials on WP rocket and did everything step by step.
Did already three times but each time with the same result. Error 1016: Origin DNS error

So, can anyone explain what I need to do, to make it work. I’ve seen the error description and even the tutorial but most of the terms are completely new to me.

I think I need to add an extra DNS info, but I am clueless what


Thank you for asking.

It did to mine website, and helped with security too :wink:

I am sorry to hear you are experiencing an 1016 error so far with your domain.

May I ask if you are using some kind of Cloudflare integration through some hosting provider maybe?

May I ask what have you tried so far from the suggestions from the article below due to this error?:

Regarding to the WP Rocket, kindly, may I ask you to follow the instructions how to propperly setup WP Rocket while using Cloudflare as follows on below articles:

In case you get some error to add IP to Cloudflare, you could achieve this by adding the origin host/server IP by navigating to the Security → Tools → IP Access Rules, enter the IP, select the action “allow” for your website :wink:

Here is a screenshot of an example:

Helpful article:

Hi Fritex,

Thanks for the response!

So the tutorials from WProcket I followed exactly. And this error also happened using a different plugin yesterday.
My hosting company doesn’t have a Coudflare option (inplesk/cpanel), so I used the WP rocket extension for it.

I have a feeling I need to change something on the DNS option in Cloudflare. There are three messages everytime I open the tab. The top two disappear after 2 seconds.
So i took a screenshot of it before it closed again.

Are these messages related to this issue?

Hi @fritex,

So doing the check @ DNS Checker - DNS Check Propagation Tool
It’s okay
But all the records CNAME, MX, NS etc. are not working.
Maybe this explains a bit more what I am doing wrong.

My hosting company solved it by adding the A host, it works now thanks!

1 Like

Thanks for feedback.

From the messages you got on the Dashboards, seems to me you are missing some DNS records and might have to add them, if so.

For example, A and A www pointed to your web hosting server IP and set to proxied :orange:. Sharing an article below for help, a tutorial which contains step-by-step instructions how to manage DNS records at Cloudflare dashboard for your domain name:

I am happy to hear it! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.