Error 1016: Origin DNS error for www.nameless-silence-22c7.testcodingworkers.dev

When I attempt to run my worker, I am given this error


How do I fix this? I’ve never seen this error before!

What’s your Worker code

addEventListener(“fetch”, (event) => {
event.respondWith(
handleRequest(event.request).catch(
(err) => new Response(err.stack, { status: 503 })
)
);
});

/**

if (pathname.startsWith("/api")) {
return new Response(JSON.stringify({ pathname }), {
headers: { “Content-Type”: “application/json” },
});
}

if (pathname.startsWith("/status")) {
const httpStatusCode = Number(pathname.split("/")[2]);

return Number.isInteger(httpStatusCode)
  ? fetch("https://www.nameless-silence-22c7.testcodingworkers.dev/" + httpStatusCode)
  : new Response("That's not a valid HTTP status code.");

}

return fetch(“https://www.nameless-silence-22c7.testcodingworkers.dev”);
}

I’m assuming you have replaced those URLs, if not, that’s why. They don’t resolve. If you have, please post the actual ones

Also, you can use codeblock
```
code
```

You mean change them to a different URL? Ok, will do!

Where do I add that (into the code)?

On the forums:
```
addEventListener(‘fetch’, …
```

will result in

addEventListener('fetch', ...

a code block. Code is readable that way

I changed the URL’S and now it’s returning a Chrome error 521

I added the code block and it’s still returning a 521 error! Do the changes take a few minutes to take effect?

That 521 is coming from the link you’re fetching.

That means that the web origin is down right? If not, then what the ■■■■ does it mean?

UPDATE: I have set Cloudflare IP’s to “Bypass” all features via my firewall rule settings! I have also created a Cloudflare client certificate
Unfortunately, I still get the error!

h