Error 1016 DriveToWeb From Google Docs Custom Domain

Full Error is: Error 1016 Ray ID: 737f1e161f08a18a • 2022-08-09 08:28:18 UTC
DriveToWeb URL that works fine is:

You have created an unresolvable situation by creating a CNAME for your apex domain that points to the www hostname while simultaneously creating a CNAME for www that points to the apex domain.

You have created a paradoxical loop: and so on, forever.

One of the two needs to have either an A or AAAA record, or use a working canonical name in another domain.

1 Like

That makes sense. Thank you. According to WHOIS, there are already two A records pointing to Cloudflare IP addresses.

I don’t have any other IP address to use in an A record so I tried a CNAME pointing to which does resolve but Cloudflare Dashboard won’t accept it. Says invalid CNAME content.

You will see I have a TXT record for DriveToWeb docs says to do this on Cloudflare. Could it be causing problems?

Whois reports the assigned authoritative naneservers for a domain. It doesn’t serve A records.

That does not look like a valid CNAME. You cannot use slashes in CNAME records. According to the Drive To Web documentation, you need create a CNAME like this:

Type: CNAME Name: www Target:

If I try that, Cloudflare says (Authentication error (Code: 10000). (see screenshot below)
The message I’ve highlighted (provided by Cloudflare) doesn’t seem to jibe with the Drive to Web documentation. by itself does not resolve but does resolve

It seems to me that points to the root of my Google drive. The drive has a folder in it called that contains an index.html

But the highlighted message implies that and are the same.

It resolves:

Your Google Drive is not properly configured to server a website at the root. I suggest you go through Google’s documentation to find the correct way to configure it.

Most likely, you’ll have to move all the files from your folder to the root directory, so it has index.html right where it belongs.

That won’t work with the Drive To Web platfrom, but your post and the one before it shed some light on why. The directions indicate that the folder name must match the hostname FQDN exactly.

Drive To Web appears to be using the hostname header in the construction of the request path used on the Google Drive account. This means it is going to require a redirect to the canonical name to occur before the request is sent to the Drive To Web host.This can be easily accomplished with either a Page Rule or a Bulk Redirect.

1 Like

Thanks for sticking with this, epic. I hope it’s interesting for you. It’s way to obscure for me.

I put a dummy index.html in the Google Drive root, just in case sdayman is onto something.

I tried to add a Bulk Redirect, got as far as the page for Creating Bulk lists but it hangs.

Probably needs a paid account.

I’ll read the Google docs some more.

You can use a limied number of Page Rules and Bulk Redirects on a free plan. Unless you have already reached the limits, this shouldn’t require changing plans.

What does your DNS look like in Cloudflare for the apex and the www records?

What is in your Bulk Redirect list?

Well, this is strange. I went back to the Dashboard and was able to Edit/Delete the CNAMEs without getting the Authentication error: 1000
So I deleted them both (I’m fairly sure they were created automatically when I first add the web site) and added the one you suggested (plus the one so the site resolves without www).

Kproxy says it works so let’s hope it really does after propagation.

That repeated error 1000 I was getting looks like a Cloudflare issue to me.

Thank you again for helping me

Your www is working, but your apex loads the site instead of your www site. Once you get either a Page Rule or a Bulk Redirect in place to send apex requests to the www hostname that should clear up.

I added this but it doesn’t seem to have made a difference.
What do think the rule should be?

Did you create both the list and the redirect portion of the Bulk Redirect? It is a multi-part process.

No, I didn’t but I have now and it seems to work.

It looks like DriveToWeb needs to update their documentation regarding Cloudflare.
They oversimplified it.
I’ll go back to them and tell them what we had to do.

Thanks for sticking with me on this, epic.

Much appreciated.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.