Error 1016 after switching to cloudflare

I’m getting an 1016 error for my site as soon as I switched nameservers to Cloudflare 8 hours ago.
My hosting company, dreamhost, said all DNS records look fine.
The only one they weren’t sure about was the cname “www”. They said this usually points to domain . com not “resolve-to. www. domain .com” as listed here with Cloudflare. Any ideas what I should do?

Please do as following:

  1. unproxy
    1.1. subdomain ftp
    1.2. subdomain ssh
    1.3. subdomain mail (unless it is a web-based mail client)
  2. resolve www correctly
    2.1. subdomain www to point to the IP of your server/hosting package or whatever.
    probably this is fixable by editing the target of the CNAME www and pointing it to domain.tld instead of resolve-to.domain.tld, as this (resolve-to.domain.tld) DNS entry does not exist.

Please try this and report back.

EDIT:

seems to have worked :slight_smile:

1 Like

Don’t skip step 1… as ALL mail/ftp/ssh related DNS entries shall be unproxied :grey:, since proxying :orange: them will break their functionality! You will not be able to log in with any FTP-Client into your server anymore (once the FTP tool re-checked the DNS and therefore will resolve to a proxied DNS).

You’re welcome, that’s what this community is for.

I don’t have any insights about what exactly happened when checking for DNS entries, but it could be some DH specific thing. Definitely not normal to CNAME to a DNS entry, that does not exist.

Unproxied these. Why does Cloudflare make this the default setting when I add my domain? “mail” is Google Workspace account - should I leave this proxied?

Nope. All mentioned shall be unproxied.

Some things need manual adjustment. Cloudflare can not magically know if you really have use the mail subdomain for resolving to an IP as validation when sending mails, or as a webclient to manage mails. The later one would be recomended beeing proxied, the first one shall not be proxied. So Cloudflare just needs to have one default - knowingly not beeing perfect for ALL, but thats how it is.


This warning ok?

Yes, if you want to use these DNS entries to connect via FTP or SSH.

Thanks! To confirm, “mail” stays proxied because it’s Google Workspace?

No, mail shall be unproxied (:grey:).

Thanks again! How do I prevent what I posted here from showing up in search engines?

What exactly? The IP? Just edit the Post and replace the picture with a picture that does have the IP censored.

I want to edit my website name out of thread. Cloudflare doesn’t give me option to edit original post…

I don’t have the power to do so myself, but I have contacted the right people which will very likely do so. As for what time it is right now, it might take a little while. But don’t worry, it shall disappear.
I will also edit my posts, to not show your domain anymore.

Have a good day!

Thanks again!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.