Error 1004, domain not propagated in 24h

Replaced Autoritative Nameservers of my domain on, after 24h my domain was not propagated. Tried CF diagnostic and had to enable DNSSec on porkbun. But nothing changed. New diagnostic error is “apex_does_not_resolve No, Cloudflare DNS could not connect to ‘’.”
Tried to proxy my server IP, but keep getting “DNS Validation Error (Code: 1004) This record type cannot be proxied.” A few months ago I could proxy in a much simpler way, what can I do now?

Can you share the domain name?

It looks like you deleted your A record yesterday and I do not see any other DNS records. Lots of good #tutorial on fixing that

Yes, it’s and yes I did delete that, but didn’t think I was “deleting” it from existence, just editing while setting things up. I will now try to understand how to fix with your links, thanks.

EDIT No, all your links are articles I’ve already read, I have already done all that. I am at the point in which I check with DNSchecker and my domain is not propagated, I have autoritative nameservers on porkbun, I have enabled DNSSec but cannot add any A record.

1 Like

Please, help, I’m stuck.

I see propagation is still not complete although it does show as active on your dash. I also see a lot of record added record deleted entries in the log, I did not verify that you are using the same IP address for the A record each time, but you may want to verify that. The error on visiting the site is not from Cloudflare.

You may want to contact your domain reigstrar to see if the icann holds on your domain are affecting nameserver propagation.


Meanwhile I have restarted from scratch, deleted everything and re-added domain, now it’s propagated. I still can’t reach my server, but that’s probably an issue with my ISP and router security settings, it’s bouncing against a DNSRebind page in the, I’m waiting for their reply.
I have bought a domain from porkbun and set Cloudflare authoritative nameservers there, so I can use it from Cloudflare.