Error 1000 for CNAME record but not for A

I have my main domain https://test.app pointing to two IPs using the A record type. I also created another record using CNAME to make my https://www.test.app canonical to https://test.app. The main domain, https://test.app, works fine while the https://www.test.app shows an Error 1000 which means that the URL is resolving to some other IP than the one main is.
I have double-checked the A records and they are all fine, it’s puzzling why the main is working while the CNAME one is not resolving.

What is the real domain and subdomain name?

Slayover.app

Can you show a screenshot of the CNAME entry?

Your A and AAAA records are all Cloudflare IP addresses. Who do you use for your website hosting?

The CNAME is, as the error says, pointing to Cloudflare IPs via slayover.app. Assuming your host is using Cloudflare, a workaround would be to set the same A/AAAA records for www instead of using a CNAME.

Alternatively use a redirect to redirect www to slayover.app (set a dummy A record of 192.0.2.1 or AAAA as 100:: in the DNS in that case).

I have hosted the app on digitalocean. Why is the main domain working while the CNAME one is the one with the issues when all cname record is doing is providing a canonical path for the original

I’ve not used Digital Ocean, so someone who has may comment.

The Digital Ocean apps appear to use Cloudflare, so the A/AAAA IP addresses you have entered belong to Cloudflare. However, Cloudflare does not allow CNAMEs to resolve to Cloudflare IP addresses through the proxy (it resolves in the DNS, but the proxy returns the error page you see).

Workarounds are probably as I posted above. Setting the CNAME to DNS only may also work, but I’m not sure.

There may also be a CNAME you can use direct to digital ocean.

There’s often odd things to configure when using a Cloudflare account with a service that also uses Cloudflare.

1 Like

I had tried not using the CNAME and instead create additional DNS records of A and AAAA but that also doesn’t work for some reason. I think it’s right that you said there is a conflict between DO and Cloudflare because DO uses Cloudflare.

The only solution is to keep trying odd methods as you said, till I decide to move to AWS.

Thanks a lot anyway.

Make sure your Digital Ocean site is configured to answer for www.slayover.app as well as the apex domain.

Had tried that before but it doesn’t work too for some reason. Solved it, digital ocean gives out a random domain with a starter URL, https://goldfish-app-hn8nf.ondigitalocean.app. I just routed the www using CNAME to this URL and it looks on the surface like things work.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.